]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/default.nix
Upgrade nixpkgs for env
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
7da3ceec
IB
4 www_root = "/run/current-system/webapps/_www";
5 theme_root = "/run/current-system/webapps/_theme";
f8bde3d6
IB
6 makeService = name: cfg: let
7 toVhost = vhostConf: {
8 enableSSL = true;
9 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
10 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
11 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
12 logFormat = "combinedVhost";
d68bb46b 13 listen = map (ip: { inherit ip; port = 443; }) cfg.ips;
f8bde3d6
IB
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
e2f5cc37 19 nosslVhost = {
d68bb46b 20 listen = map (ip: { inherit ip; port = 80; }) cfg.ips;
e2f5cc37
IB
21 hostName = "nossl.immae.eu";
22 enableSSL = false;
23 logFormat = "combinedVhost";
7da3ceec 24 documentRoot = www_root;
e2f5cc37 25 extraConfig = ''
7da3ceec 26 <Directory ${www_root}>
e2f5cc37
IB
27 DirectoryIndex nossl.html
28 AllowOverride None
29 Require all granted
30
31 RewriteEngine on
32 RewriteRule ^/(.+) / [L]
33 </Directory>
34 '';
35 };
950ca5ee 36 redirectVhost = { # Should go last, catchall http -> https redirect
d68bb46b 37 listen = map (ip: { inherit ip; port = 80; }) cfg.ips;
950ca5ee
IB
38 hostName = "redirectSSL";
39 serverAliases = [ "*" ];
40 enableSSL = false;
41 logFormat = "combinedVhost";
42 documentRoot = "/var/lib/acme/acme-challenge";
43 extraConfig = ''
44 RewriteEngine on
45 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
46 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
47 # To redirect in specific "VirtualHost *:80", do
48 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
49 # rather than rewrite
50 '';
51 };
52 fallbackVhost = toVhost { # Should go first, default choice
53 certName = "eldiron";
54 hosts = ["eldiron.immae.eu" ];
7da3ceec 55 root = www_root;
950ca5ee
IB
56 extraConfig = [ "DirectoryIndex index.htm" ];
57 };
f8bde3d6
IB
58 in rec {
59 enable = true;
d68bb46b 60 listen = map (ip: { inherit ip; port = 443; }) cfg.ips;
f8bde3d6
IB
61 stateDir = "/run/httpd_${name}";
62 logPerVirtualHost = true;
63 multiProcessingModule = "worker";
64 adminAddr = "httpd@immae.eu";
65 logFormat = "combinedVhost";
66 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
67 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee 68 virtualHosts = [ fallbackVhost ]
e2f5cc37 69 ++ lib.optionals (name == "tools") [ nosslVhost ]
950ca5ee
IB
70 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
71 ++ [ redirectVhost ];
f8bde3d6 72 };
d68bb46b 73 makeServiceOptions = name: {
f8bde3d6 74 enable = lib.mkEnableOption "enable websites in ${name}";
d68bb46b
IB
75 ips = lib.mkOption {
76 type = lib.types.listOf lib.types.string;
77 default = let
78 ips = myconfig.env.servers.eldiron.ips.${name};
79 in
80 [ips.ip4] ++ (ips.ip6 or []);
81 description = "${name} ips to listen to";
f8bde3d6
IB
82 };
83 modules = lib.mkOption {
84 type = lib.types.listOf (lib.types.str);
85 default = [];
86 };
87 extraConfig = lib.mkOption {
88 type = lib.types.listOf (lib.types.lines);
89 default = [];
90 };
91 vhostConfs = lib.mkOption {
92 type = lib.types.attrsOf (lib.types.submodule {
93 options = {
94 certName = lib.mkOption { type = lib.types.string; };
95 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
96 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
97 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
98 };
99 });
100 };
101 };
f8d3b61a
IB
102 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
103 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
104in
105{
106 imports = [
54307da4
IB
107 ./chloe
108 ./ludivine
109 ./aten
110 ./piedsjaloux
111 ./connexionswing
2f0f1c48 112 ./tellesflorian
9a35b8f9 113 ./emilia
10bd8c08 114 ./capitaines
d578d270 115 ./ftp/jerome.nix
53b8fad9 116 ./ftp/nassime.nix
79f239be 117 ./ftp/florian.nix
dc9fb826 118 ./ftp/denisejerome.nix
c336bac4 119 ./ftp/leila.nix
f759f52e 120 ./ftp/immae.nix
ce493c5d
IB
121 ./ftp/release.nix
122 ./ftp/temp.nix
10889174
IB
123 ./tools/db
124 ./tools/tools
125 ./tools/dav
126 ./tools/cloud
127 ./tools/git
35a397cd 128 ./tools/mastodon
56eba416 129 ./tools/mediagoblin
a7f7fdae 130 ./tools/diaspora
17146204 131 ./tools/ether
0eaac6ba 132 ./tools/peertube
f8bde3d6
IB
133 # built using:
134 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 135 # Removed allGranted
f8bde3d6 136 # And removed users / groups
54307da4
IB
137 ./apache/httpd_prod.nix
138 ./apache/httpd_inte.nix
273e2c61
IB
139 # except for this one for users/groups
140 ./apache/httpd_tools.nix
10889174
IB
141 # Adapted from base phpfpm
142 ./phpfpm
42429ef0
IB
143 ];
144
145 options.services.myWebsites = {
d68bb46b
IB
146 production = makeServiceOptions "production";
147 integration = makeServiceOptions "integration";
148 tools = makeServiceOptions "main";
42429ef0
IB
149
150 apacheConfig = lib.mkOption {
151 type = lib.types.attrsOf (lib.types.submodule {
152 options = {
153 modules = lib.mkOption {
154 type = lib.types.listOf (lib.types.str);
155 default = [];
156 };
157 extraConfig = lib.mkOption {
158 type = lib.types.nullOr lib.types.lines;
159 default = null;
160 };
161 };
162 });
163 default = {};
164 description = "Extra global config";
165 };
166
167 };
168
169 config = {
d68bb46b 170 networking.firewall.allowedTCPPorts = [ 80 443 ];
54307da4 171
2368a4b7 172 nixpkgs.overlays = [ (self: super: rec {
e2ca51b2 173 #openssl = self.openssl_1_1;
98584540 174 php = php72;
2368a4b7
IB
175 php72 = (super.php72.override {
176 mysql.connector-c = self.mariadb;
98584540
IB
177 config.php.mysqlnd = false;
178 config.php.mysqli = false;
179 }).overrideAttrs(old: rec {
180 # Didn't manage to build with mysqli + mysql_config connector
181 configureFlags = old.configureFlags ++ [
912921a7 182 "--with-mysqli=shared,mysqlnd"
98584540
IB
183 ];
184 # preConfigure = (old.preConfigure or "") + ''
185 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
186 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
187 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
188 # '';
189 });
2368a4b7 190 phpPackages = super.php72Packages.override { inherit php; };
d78128ec 191 composerEnv = import ./commons/composer-env.nix {
2368a4b7 192 inherit (self) stdenv writeTextFile fetchurl php unzip;
d78128ec 193 };
2368a4b7 194 }) ];
98584540 195
10889174
IB
196 services.myWebsites.tools.databases.enable = true;
197 services.myWebsites.tools.tools.enable = true;
198 services.myWebsites.tools.dav.enable = true;
199 services.myWebsites.tools.cloud.enable = true;
200 services.myWebsites.tools.git.enable = true;
35a397cd 201 services.myWebsites.tools.mastodon.enable = true;
56eba416 202 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 203 services.myWebsites.tools.diaspora.enable = true;
17146204 204 services.myWebsites.tools.etherpad-lite.enable = true;
0eaac6ba 205 services.myWebsites.tools.peertube.enable = true;
10889174 206
42429ef0
IB
207 services.myWebsites.Chloe.production.enable = cfg.production.enable;
208 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
209 services.myWebsites.Aten.production.enable = cfg.production.enable;
210 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
211 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
d578d270 212 services.myWebsites.Jerome.production.enable = cfg.production.enable;
53b8fad9 213 services.myWebsites.Nassime.production.enable = cfg.production.enable;
79f239be 214 services.myWebsites.Florian.production.enable = cfg.production.enable;
c336bac4 215 services.myWebsites.Leila.production.enable = cfg.production.enable;
dc9fb826 216 services.myWebsites.DeniseJerome.production.enable = cfg.production.enable;
9a35b8f9 217 services.myWebsites.Emilia.production.enable = cfg.production.enable;
10bd8c08 218 services.myWebsites.Capitaines.production.enable = cfg.production.enable;
f759f52e 219 services.myWebsites.Immae.production.enable = cfg.production.enable;
ce493c5d
IB
220 services.myWebsites.Release.production.enable = cfg.production.enable;
221 services.myWebsites.Temp.production.enable = cfg.production.enable;
42429ef0
IB
222
223 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
224 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
225 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
226 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
227 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 228 services.myWebsites.TellesFlorian.integration.enable = true;
79f239be 229 services.myWebsites.Florian.integration.enable = true;
42429ef0
IB
230
231 services.myWebsites.apacheConfig = {
232 gzip = {
233 modules = [ "deflate" "filter" ];
234 extraConfig = ''
235 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
236 '';
237 };
238 macros = {
239 modules = [ "macro" ];
240 };
ce493c5d
IB
241 stats = {
242 extraConfig = ''
243 <Macro Stats %{domain}>
244 Alias /awstats /var/lib/goaccess/%{domain}
245 <Directory /var/lib/goaccess/%{domain}>
246 DirectoryIndex index.html
247 AllowOverride None
248 Require all granted
249 </Directory>
250 <Location /awstats>
251 Use LDAPConnect
252 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
253 </Location>
254 </Macro>
255 '';
256 };
42429ef0
IB
257 ldap = {
258 modules = [ "ldap" "authnz_ldap" ];
9d90e7e2 259 extraConfig = ''
42429ef0
IB
260 <IfModule ldap_module>
261 LDAPSharedCacheSize 500000
262 LDAPCacheEntries 1024
263 LDAPCacheTTL 600
264 LDAPOpCacheEntries 1024
265 LDAPOpCacheTTL 600
266 </IfModule>
267
268 <Macro LDAPConnect>
269 <IfModule authnz_ldap_module>
270 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
271 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
9d90e7e2 272 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
42429ef0
IB
273 AuthType Basic
274 AuthName "Authentification requise (Acces LDAP)"
275 AuthBasicProvider ldap
276 </IfModule>
277 </Macro>
ce493c5d
IB
278 '';
279 };
280 global = {
281 extraConfig = ''
646bdf3e
IB
282 ErrorDocument 500 /maintenance_immae.html
283 ErrorDocument 501 /maintenance_immae.html
284 ErrorDocument 502 /maintenance_immae.html
285 ErrorDocument 503 /maintenance_immae.html
286 ErrorDocument 504 /maintenance_immae.html
7da3ceec 287 Alias /maintenance_immae.html ${www_root}/maintenance_immae.html
646bdf3e
IB
288 ProxyPass /maintenance_immae.html !
289
7da3ceec
IB
290 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${www_root}/googleb6d69446ff4ca3e5.html
291 <Directory ${www_root}>
d06ed384
IB
292 AllowOverride None
293 Require all granted
294 </Directory>
42429ef0
IB
295 '';
296 };
ce493c5d
IB
297 apaxy = {
298 extraConfig = ''
299 <Macro Apaxy %{folder} %{ignored}>
7da3ceec
IB
300 Alias /theme ${theme_root}
301 <Directory ${theme_root}>
ce493c5d
IB
302 Options -Indexes
303 AllowOverride None
304 Require all granted
305 </Directory>
306
307 # mod_autoindex
308 <Directory %{folder}>
309 Options Indexes
310 AllowOverride None
311 Require all granted
312
313 # Inspired from Apaxy by @adamwhitcroft
314
315 IndexOptions +Charset=UTF-8 +FancyIndexing +IgnoreCase +FoldersFirst +XHTML +HTMLTable +SuppressRules +SuppressDescription +NameWidth=* +IconsAreLinks +ShowForbidden
316
317 IndexHeadInsert "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" />"
318
319 IndexIgnoreReset ON
320 IndexIgnore /theme .htaccess %{ignored}
321
322 AddIcon /theme/icons/blank.png ^^BLANKICON^^
323 AddIcon /theme/icons/folder.png ^^DIRECTORY^^
324 AddIcon /theme/icons/folder-home.png ..
325
326 AddIconByType (TXT,/theme/icons/text.png) text/*
327 AddIconByType (IMG,/theme/icons/image.png) image/*
328 AddIconByType (SND,/theme/icons/audio.png) audio/*
329 AddIconByType (VID,/theme/icons/video.png) video/*
330
331 AddIcon /theme/icons/archive.png .7z .bz2 .cab .gz .tar
332 AddIcon /theme/icons/audio.png .aac .aif .aifc .aiff .ape .au .flac .iff .m4a .mid .mp3 .mpa .ra .wav .wma .f4a .f4b .oga .ogg .xm .it .s3m .mod
333 AddIcon /theme/icons/bin.png .bin .hex
334 AddIcon /theme/icons/bmp.png .bmp
335 AddIcon /theme/icons/c.png .c
336 AddIcon /theme/icons/calc.png .xlsx .xlsm .xltx .xltm .xlam .xlr .xls .csv
337 AddIcon /theme/icons/cd.png .iso
338 AddIcon /theme/icons/cpp.png .cpp
339 AddIcon /theme/icons/css.png .css .sass .scss
340 AddIcon /theme/icons/deb.png .deb
341 AddIcon /theme/icons/doc.png .doc .docx .docm .dot .dotx .dotm .log .msg .odt .pages .rtf .tex .wpd .wps
342 AddIcon /theme/icons/draw.png .svg .svgz
343 AddIcon /theme/icons/eps.png .ai .eps
344 AddIcon /theme/icons/exe.png .exe
345 AddIcon /theme/icons/gif.png .gif
346 AddIcon /theme/icons/h.png .h
347 AddIcon /theme/icons/html.png .html .xhtml .shtml .htm .URL .url
348 AddIcon /theme/icons/ico.png .ico
349 AddIcon /theme/icons/java.png .jar
350 AddIcon /theme/icons/jpg.png .jpg .jpeg .jpe
351 AddIcon /theme/icons/js.png .js .json
352 AddIcon /theme/icons/markdown.png .md
353 AddIcon /theme/icons/package.png .pkg .dmg
354 AddIcon /theme/icons/pdf.png .pdf
355 AddIcon /theme/icons/php.png .php .phtml
356 AddIcon /theme/icons/playlist.png .m3u .m3u8 .pls .pls8
357 AddIcon /theme/icons/png.png .png
358 AddIcon /theme/icons/ps.png .ps
359 AddIcon /theme/icons/psd.png .psd
360 AddIcon /theme/icons/py.png .py
361 AddIcon /theme/icons/rar.png .rar
362 AddIcon /theme/icons/rb.png .rb
363 AddIcon /theme/icons/rpm.png .rpm
364 AddIcon /theme/icons/rss.png .rss
365 AddIcon /theme/icons/script.png .bat .cmd .sh
366 AddIcon /theme/icons/sql.png .sql
367 AddIcon /theme/icons/tiff.png .tiff .tif
368 AddIcon /theme/icons/text.png .txt .nfo
369 AddIcon /theme/icons/video.png .asf .asx .avi .flv .mkv .mov .mp4 .mpg .rm .srt .swf .vob .wmv .m4v .f4v .f4p .ogv
370 AddIcon /theme/icons/xml.png .xml
371 AddIcon /theme/icons/zip.png .zip
372 DefaultIcon /theme/icons/default.png
373
374 HeaderName /theme/header.html
375 ReadmeName /theme/footer.html
376 IndexStyleSheet /theme/style.css
377 </Directory>
378 </Macro>
379 '';
380 };
42429ef0
IB
381 http2 = {
382 modules = [ "http2" ];
383 extraConfig = ''
384 Protocols h2 http/1.1
385 '';
386 };
387 customLog = {
388 extraConfig = ''
389 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
390 '';
391 };
392 };
f8bde3d6 393
10889174
IB
394 system.activationScripts = {
395 httpd = ''
396 install -d -m 0755 /var/lib/acme/acme-challenge
397 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
398 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
399 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
400 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
401 '';
402 };
403
7da3ceec
IB
404 system.extraSystemBuilderCmds = let
405 adminer = pkgs.callPackage ./commons/adminer.nix {};
406 in ''
407 mkdir -p $out/webapps
408 ln -s ${../../www} $out/webapps/_www
409 ln -s ${./apache/theme} $out/webapps/_theme
410 ln -s ${adminer.webRoot} $out/webapps/${adminer.apache.webappName}
411 '';
412
10889174
IB
413 services.myPhpfpm = {
414 phpPackage = pkgs.php;
415 phpOptions = ''
416 session.save_path = "/var/lib/php/sessions"
95b20e17 417 post_max_size = 20M
10889174
IB
418 session.gc_maxlifetime = 60*60*24*15
419 session.cache_expire = 60*24*30
420 '';
421 extraConfig = ''
422 log_level = notice
423 '';
424 };
425
f8bde3d6 426 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
427 services.myWebsites.production.modules = makeModules cfg;
428 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
429
430 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
431 services.myWebsites.integration.modules = makeModules cfg;
432 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 433
273e2c61 434 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
435 services.myWebsites.tools.modules = makeModules cfg;
436 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
437 [ ''
438 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
439 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
440 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
441 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
442 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
443 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
444 ''
445 ]
446 ;
42429ef0
IB
447 };
448}