]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/default.nix
Change Chloe spip version
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
f8bde3d6
IB
4 makeService = name: cfg: let
5 toVhost = vhostConf: {
6 enableSSL = true;
7 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
8 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
9 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
10 logFormat = "combinedVhost";
11 listen = [
12 { ip = cfg.ip; port = 443; }
13 ];
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
950ca5ee
IB
19 redirectVhost = { # Should go last, catchall http -> https redirect
20 listen = [ { ip = cfg.ip; port = 80; } ];
21 hostName = "redirectSSL";
22 serverAliases = [ "*" ];
23 enableSSL = false;
24 logFormat = "combinedVhost";
25 documentRoot = "/var/lib/acme/acme-challenge";
26 extraConfig = ''
27 RewriteEngine on
28 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
29 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
30 # To redirect in specific "VirtualHost *:80", do
31 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
32 # rather than rewrite
33 '';
34 };
35 fallbackVhost = toVhost { # Should go first, default choice
36 certName = "eldiron";
37 hosts = ["eldiron.immae.eu" ];
38 root = ../../www;
39 extraConfig = [ "DirectoryIndex index.htm" ];
40 };
f8bde3d6
IB
41 in rec {
42 enable = true;
43 listen = [
44 { ip = cfg.ip; port = 443; }
45 ];
46 stateDir = "/run/httpd_${name}";
47 logPerVirtualHost = true;
48 multiProcessingModule = "worker";
49 adminAddr = "httpd@immae.eu";
50 logFormat = "combinedVhost";
51 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
52 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
53 virtualHosts = [ fallbackVhost ]
54 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
55 ++ [ redirectVhost ];
f8bde3d6
IB
56 };
57 makeServiceOptions = name: ip: {
58 enable = lib.mkEnableOption "enable websites in ${name}";
59 ip = lib.mkOption {
60 type = lib.types.string;
61 default = ip;
62 description = "${name} ip to listen to";
63 };
64 modules = lib.mkOption {
65 type = lib.types.listOf (lib.types.str);
66 default = [];
67 };
68 extraConfig = lib.mkOption {
69 type = lib.types.listOf (lib.types.lines);
70 default = [];
71 };
72 vhostConfs = lib.mkOption {
73 type = lib.types.attrsOf (lib.types.submodule {
74 options = {
75 certName = lib.mkOption { type = lib.types.string; };
76 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
77 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
78 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
79 };
80 });
81 };
82 };
f8d3b61a
IB
83 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
84 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
85in
86{
87 imports = [
54307da4
IB
88 ./chloe
89 ./ludivine
90 ./aten
91 ./piedsjaloux
92 ./connexionswing
2f0f1c48 93 ./tellesflorian
10889174
IB
94 ./tools/db
95 ./tools/tools
96 ./tools/dav
97 ./tools/cloud
98 ./tools/git
35a397cd 99 ./tools/mastodon
56eba416 100 ./tools/mediagoblin
a7f7fdae 101 ./tools/diaspora
f8bde3d6
IB
102 # built using:
103 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 104 # Removed allGranted
f8bde3d6 105 # And removed users / groups
54307da4
IB
106 ./apache/httpd_prod.nix
107 ./apache/httpd_inte.nix
273e2c61
IB
108 # except for this one for users/groups
109 ./apache/httpd_tools.nix
10889174
IB
110 # Adapted from base phpfpm
111 ./phpfpm
42429ef0
IB
112 ];
113
114 options.services.myWebsites = {
f8bde3d6
IB
115 production = makeServiceOptions "production" myconfig.ips.production;
116 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 117 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
118
119 apacheConfig = lib.mkOption {
120 type = lib.types.attrsOf (lib.types.submodule {
121 options = {
122 modules = lib.mkOption {
123 type = lib.types.listOf (lib.types.str);
124 default = [];
125 };
126 extraConfig = lib.mkOption {
127 type = lib.types.nullOr lib.types.lines;
128 default = null;
129 };
130 };
131 });
132 default = {};
133 description = "Extra global config";
134 };
135
136 };
137
138 config = {
54307da4
IB
139 networking = {
140 firewall = {
141 enable = true;
142 allowedTCPPorts = [ 80 443 ];
143 };
144 interfaces."eth0".ipv4.addresses = [
145 # 176.9.151.89 declared in nixops -> infra / tools
146 { address = myconfig.ips.production; prefixLength = 32; }
147 { address = myconfig.ips.integration; prefixLength = 32; }
148 ];
149 };
150
98584540
IB
151 nixpkgs.config.packageOverrides = oldpkgs: rec {
152 php = php72;
153 php72 = (oldpkgs.php72.override {
154 mysql.connector-c = pkgs.mariadb;
155 config.php.mysqlnd = false;
156 config.php.mysqli = false;
157 }).overrideAttrs(old: rec {
158 # Didn't manage to build with mysqli + mysql_config connector
159 configureFlags = old.configureFlags ++ [
912921a7 160 "--with-mysqli=shared,mysqlnd"
98584540
IB
161 ];
162 # preConfigure = (old.preConfigure or "") + ''
163 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
164 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
165 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
166 # '';
167 });
168 phpPackages = oldpkgs.php72Packages.override { inherit php; };
169 };
170
10889174
IB
171 services.myWebsites.tools.databases.enable = true;
172 services.myWebsites.tools.tools.enable = true;
173 services.myWebsites.tools.dav.enable = true;
174 services.myWebsites.tools.cloud.enable = true;
175 services.myWebsites.tools.git.enable = true;
35a397cd 176 services.myWebsites.tools.mastodon.enable = true;
56eba416 177 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 178 services.myWebsites.tools.diaspora.enable = true;
10889174 179
42429ef0
IB
180 services.myWebsites.Chloe.production.enable = cfg.production.enable;
181 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
182 services.myWebsites.Aten.production.enable = cfg.production.enable;
183 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
184 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
185
186 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
187 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
188 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
189 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
190 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 191 services.myWebsites.TellesFlorian.integration.enable = true;
42429ef0
IB
192
193 services.myWebsites.apacheConfig = {
194 gzip = {
195 modules = [ "deflate" "filter" ];
196 extraConfig = ''
197 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
198 '';
199 };
200 macros = {
201 modules = [ "macro" ];
202 };
203 ldap = {
204 modules = [ "ldap" "authnz_ldap" ];
9d90e7e2 205 extraConfig = ''
42429ef0
IB
206 <IfModule ldap_module>
207 LDAPSharedCacheSize 500000
208 LDAPCacheEntries 1024
209 LDAPCacheTTL 600
210 LDAPOpCacheEntries 1024
211 LDAPOpCacheTTL 600
212 </IfModule>
213
214 <Macro LDAPConnect>
215 <IfModule authnz_ldap_module>
216 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
217 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
9d90e7e2 218 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
42429ef0
IB
219 AuthType Basic
220 AuthName "Authentification requise (Acces LDAP)"
221 AuthBasicProvider ldap
222 </IfModule>
223 </Macro>
224
225 <Macro Stats %{domain}>
226 Alias /awstats /var/lib/goaccess/%{domain}
227 <Directory /var/lib/goaccess/%{domain}>
228 DirectoryIndex index.html
229 AllowOverride None
230 Require all granted
231 </Directory>
232 <Location /awstats>
233 Use LDAPConnect
234 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
235 </Location>
236 </Macro>
646bdf3e
IB
237
238 ErrorDocument 500 /maintenance_immae.html
239 ErrorDocument 501 /maintenance_immae.html
240 ErrorDocument 502 /maintenance_immae.html
241 ErrorDocument 503 /maintenance_immae.html
242 ErrorDocument 504 /maintenance_immae.html
243 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
244 ProxyPass /maintenance_immae.html !
245
246 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
247 '';
248 };
249 http2 = {
250 modules = [ "http2" ];
251 extraConfig = ''
252 Protocols h2 http/1.1
253 '';
254 };
255 customLog = {
256 extraConfig = ''
257 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
258 '';
259 };
260 };
f8bde3d6 261
10889174
IB
262 system.activationScripts = {
263 httpd = ''
264 install -d -m 0755 /var/lib/acme/acme-challenge
265 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
266 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
267 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
268 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
269 '';
270 };
271
272 services.myPhpfpm = {
273 phpPackage = pkgs.php;
274 phpOptions = ''
275 session.save_path = "/var/lib/php/sessions"
276 session.gc_maxlifetime = 60*60*24*15
277 session.cache_expire = 60*24*30
278 '';
279 extraConfig = ''
280 log_level = notice
281 '';
282 };
283
f8bde3d6 284 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
285 services.myWebsites.production.modules = makeModules cfg;
286 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
287
288 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
289 services.myWebsites.integration.modules = makeModules cfg;
290 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 291
273e2c61 292 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
293 services.myWebsites.tools.modules = makeModules cfg;
294 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
295 [ ''
296 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
297 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
298 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
299 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
300 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
301 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
302 ''
303 ]
304 ;
42429ef0
IB
305 };
306}