]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/default.nix
Move Émilia's website
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
f8bde3d6
IB
4 makeService = name: cfg: let
5 toVhost = vhostConf: {
6 enableSSL = true;
7 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
8 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
9 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
10 logFormat = "combinedVhost";
11 listen = [
12 { ip = cfg.ip; port = 443; }
13 ];
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
950ca5ee
IB
19 redirectVhost = { # Should go last, catchall http -> https redirect
20 listen = [ { ip = cfg.ip; port = 80; } ];
21 hostName = "redirectSSL";
22 serverAliases = [ "*" ];
23 enableSSL = false;
24 logFormat = "combinedVhost";
25 documentRoot = "/var/lib/acme/acme-challenge";
26 extraConfig = ''
27 RewriteEngine on
28 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
29 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
30 # To redirect in specific "VirtualHost *:80", do
31 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
32 # rather than rewrite
33 '';
34 };
35 fallbackVhost = toVhost { # Should go first, default choice
36 certName = "eldiron";
37 hosts = ["eldiron.immae.eu" ];
38 root = ../../www;
39 extraConfig = [ "DirectoryIndex index.htm" ];
40 };
f8bde3d6
IB
41 in rec {
42 enable = true;
43 listen = [
44 { ip = cfg.ip; port = 443; }
45 ];
46 stateDir = "/run/httpd_${name}";
47 logPerVirtualHost = true;
48 multiProcessingModule = "worker";
49 adminAddr = "httpd@immae.eu";
50 logFormat = "combinedVhost";
51 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
52 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
53 virtualHosts = [ fallbackVhost ]
54 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
55 ++ [ redirectVhost ];
f8bde3d6
IB
56 };
57 makeServiceOptions = name: ip: {
58 enable = lib.mkEnableOption "enable websites in ${name}";
59 ip = lib.mkOption {
60 type = lib.types.string;
61 default = ip;
62 description = "${name} ip to listen to";
63 };
64 modules = lib.mkOption {
65 type = lib.types.listOf (lib.types.str);
66 default = [];
67 };
68 extraConfig = lib.mkOption {
69 type = lib.types.listOf (lib.types.lines);
70 default = [];
71 };
72 vhostConfs = lib.mkOption {
73 type = lib.types.attrsOf (lib.types.submodule {
74 options = {
75 certName = lib.mkOption { type = lib.types.string; };
76 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
77 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
78 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
79 };
80 });
81 };
82 };
f8d3b61a
IB
83 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
84 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
85in
86{
87 imports = [
54307da4
IB
88 ./chloe
89 ./ludivine
90 ./aten
91 ./piedsjaloux
92 ./connexionswing
2f0f1c48 93 ./tellesflorian
9a35b8f9 94 ./emilia
d578d270 95 ./ftp/jerome.nix
53b8fad9 96 ./ftp/nassime.nix
79f239be 97 ./ftp/florian.nix
dc9fb826 98 ./ftp/denisejerome.nix
10889174
IB
99 ./tools/db
100 ./tools/tools
101 ./tools/dav
102 ./tools/cloud
103 ./tools/git
35a397cd 104 ./tools/mastodon
56eba416 105 ./tools/mediagoblin
a7f7fdae 106 ./tools/diaspora
17146204 107 ./tools/ether
f8bde3d6
IB
108 # built using:
109 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 110 # Removed allGranted
f8bde3d6 111 # And removed users / groups
54307da4
IB
112 ./apache/httpd_prod.nix
113 ./apache/httpd_inte.nix
273e2c61
IB
114 # except for this one for users/groups
115 ./apache/httpd_tools.nix
10889174
IB
116 # Adapted from base phpfpm
117 ./phpfpm
42429ef0
IB
118 ];
119
120 options.services.myWebsites = {
f8bde3d6
IB
121 production = makeServiceOptions "production" myconfig.ips.production;
122 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 123 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
124
125 apacheConfig = lib.mkOption {
126 type = lib.types.attrsOf (lib.types.submodule {
127 options = {
128 modules = lib.mkOption {
129 type = lib.types.listOf (lib.types.str);
130 default = [];
131 };
132 extraConfig = lib.mkOption {
133 type = lib.types.nullOr lib.types.lines;
134 default = null;
135 };
136 };
137 });
138 default = {};
139 description = "Extra global config";
140 };
141
142 };
143
144 config = {
54307da4
IB
145 networking = {
146 firewall = {
147 enable = true;
148 allowedTCPPorts = [ 80 443 ];
149 };
150 interfaces."eth0".ipv4.addresses = [
151 # 176.9.151.89 declared in nixops -> infra / tools
152 { address = myconfig.ips.production; prefixLength = 32; }
153 { address = myconfig.ips.integration; prefixLength = 32; }
154 ];
155 };
156
98584540
IB
157 nixpkgs.config.packageOverrides = oldpkgs: rec {
158 php = php72;
159 php72 = (oldpkgs.php72.override {
160 mysql.connector-c = pkgs.mariadb;
161 config.php.mysqlnd = false;
162 config.php.mysqli = false;
163 }).overrideAttrs(old: rec {
164 # Didn't manage to build with mysqli + mysql_config connector
165 configureFlags = old.configureFlags ++ [
912921a7 166 "--with-mysqli=shared,mysqlnd"
98584540
IB
167 ];
168 # preConfigure = (old.preConfigure or "") + ''
169 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
170 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
171 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
172 # '';
173 });
174 phpPackages = oldpkgs.php72Packages.override { inherit php; };
d78128ec
IB
175 composerEnv = import ./commons/composer-env.nix {
176 inherit (pkgs) stdenv writeTextFile fetchurl php unzip;
177 };
98584540
IB
178 };
179
10889174
IB
180 services.myWebsites.tools.databases.enable = true;
181 services.myWebsites.tools.tools.enable = true;
182 services.myWebsites.tools.dav.enable = true;
183 services.myWebsites.tools.cloud.enable = true;
184 services.myWebsites.tools.git.enable = true;
35a397cd 185 services.myWebsites.tools.mastodon.enable = true;
56eba416 186 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 187 services.myWebsites.tools.diaspora.enable = true;
17146204 188 services.myWebsites.tools.etherpad-lite.enable = true;
10889174 189
42429ef0
IB
190 services.myWebsites.Chloe.production.enable = cfg.production.enable;
191 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
192 services.myWebsites.Aten.production.enable = cfg.production.enable;
193 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
194 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
d578d270 195 services.myWebsites.Jerome.production.enable = cfg.production.enable;
53b8fad9 196 services.myWebsites.Nassime.production.enable = cfg.production.enable;
79f239be 197 services.myWebsites.Florian.production.enable = cfg.production.enable;
dc9fb826 198 services.myWebsites.DeniseJerome.production.enable = cfg.production.enable;
9a35b8f9 199 services.myWebsites.Emilia.production.enable = cfg.production.enable;
42429ef0
IB
200
201 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
202 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
203 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
204 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
205 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 206 services.myWebsites.TellesFlorian.integration.enable = true;
79f239be 207 services.myWebsites.Florian.integration.enable = true;
42429ef0
IB
208
209 services.myWebsites.apacheConfig = {
210 gzip = {
211 modules = [ "deflate" "filter" ];
212 extraConfig = ''
213 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
214 '';
215 };
216 macros = {
217 modules = [ "macro" ];
218 };
219 ldap = {
220 modules = [ "ldap" "authnz_ldap" ];
9d90e7e2 221 extraConfig = ''
42429ef0
IB
222 <IfModule ldap_module>
223 LDAPSharedCacheSize 500000
224 LDAPCacheEntries 1024
225 LDAPCacheTTL 600
226 LDAPOpCacheEntries 1024
227 LDAPOpCacheTTL 600
228 </IfModule>
229
230 <Macro LDAPConnect>
231 <IfModule authnz_ldap_module>
232 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
233 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
9d90e7e2 234 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
42429ef0
IB
235 AuthType Basic
236 AuthName "Authentification requise (Acces LDAP)"
237 AuthBasicProvider ldap
238 </IfModule>
239 </Macro>
240
241 <Macro Stats %{domain}>
242 Alias /awstats /var/lib/goaccess/%{domain}
243 <Directory /var/lib/goaccess/%{domain}>
244 DirectoryIndex index.html
245 AllowOverride None
246 Require all granted
247 </Directory>
248 <Location /awstats>
249 Use LDAPConnect
250 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
251 </Location>
252 </Macro>
646bdf3e
IB
253
254 ErrorDocument 500 /maintenance_immae.html
255 ErrorDocument 501 /maintenance_immae.html
256 ErrorDocument 502 /maintenance_immae.html
257 ErrorDocument 503 /maintenance_immae.html
258 ErrorDocument 504 /maintenance_immae.html
259 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
260 ProxyPass /maintenance_immae.html !
261
262 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
263 '';
264 };
265 http2 = {
266 modules = [ "http2" ];
267 extraConfig = ''
268 Protocols h2 http/1.1
269 '';
270 };
271 customLog = {
272 extraConfig = ''
273 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
274 '';
275 };
276 };
f8bde3d6 277
10889174
IB
278 system.activationScripts = {
279 httpd = ''
280 install -d -m 0755 /var/lib/acme/acme-challenge
281 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
282 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
283 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
284 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
285 '';
286 };
287
288 services.myPhpfpm = {
289 phpPackage = pkgs.php;
290 phpOptions = ''
291 session.save_path = "/var/lib/php/sessions"
292 session.gc_maxlifetime = 60*60*24*15
293 session.cache_expire = 60*24*30
294 '';
295 extraConfig = ''
296 log_level = notice
297 '';
298 };
299
f8bde3d6 300 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
301 services.myWebsites.production.modules = makeModules cfg;
302 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
303
304 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
305 services.myWebsites.integration.modules = makeModules cfg;
306 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 307
273e2c61 308 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
309 services.myWebsites.tools.modules = makeModules cfg;
310 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
311 [ ''
312 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
313 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
314 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
315 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
316 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
317 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
318 ''
319 ]
320 ;
42429ef0
IB
321 };
322}