]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/default.nix
Fix deprecation for networking addresses in hetzner
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0 2let
950ca5ee
IB
3 mypkgs = pkgs.callPackage ../../packages.nix {
4 inherit (mylibs) checkEnv fetchedGit fetchedGithub;
5 };
42429ef0 6 cfg = config.services.myWebsites;
f8bde3d6
IB
7 makeService = name: cfg: let
8 toVhost = vhostConf: {
9 enableSSL = true;
10 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
11 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
12 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
13 logFormat = "combinedVhost";
14 listen = [
15 { ip = cfg.ip; port = 443; }
16 ];
17 hostName = builtins.head vhostConf.hosts;
18 serverAliases = builtins.tail vhostConf.hosts or [];
19 documentRoot = vhostConf.root;
20 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
21 };
950ca5ee
IB
22 redirectVhost = { # Should go last, catchall http -> https redirect
23 listen = [ { ip = cfg.ip; port = 80; } ];
24 hostName = "redirectSSL";
25 serverAliases = [ "*" ];
26 enableSSL = false;
27 logFormat = "combinedVhost";
28 documentRoot = "/var/lib/acme/acme-challenge";
29 extraConfig = ''
30 RewriteEngine on
31 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
32 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
33 # To redirect in specific "VirtualHost *:80", do
34 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
35 # rather than rewrite
36 '';
37 };
38 fallbackVhost = toVhost { # Should go first, default choice
39 certName = "eldiron";
40 hosts = ["eldiron.immae.eu" ];
41 root = ../../www;
42 extraConfig = [ "DirectoryIndex index.htm" ];
43 };
f8bde3d6
IB
44 in rec {
45 enable = true;
46 listen = [
47 { ip = cfg.ip; port = 443; }
48 ];
49 stateDir = "/run/httpd_${name}";
50 logPerVirtualHost = true;
51 multiProcessingModule = "worker";
52 adminAddr = "httpd@immae.eu";
53 logFormat = "combinedVhost";
54 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
55 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
56 virtualHosts = [ fallbackVhost ]
57 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
58 ++ [ redirectVhost ];
f8bde3d6
IB
59 };
60 makeServiceOptions = name: ip: {
61 enable = lib.mkEnableOption "enable websites in ${name}";
62 ip = lib.mkOption {
63 type = lib.types.string;
64 default = ip;
65 description = "${name} ip to listen to";
66 };
67 modules = lib.mkOption {
68 type = lib.types.listOf (lib.types.str);
69 default = [];
70 };
71 extraConfig = lib.mkOption {
72 type = lib.types.listOf (lib.types.lines);
73 default = [];
74 };
75 vhostConfs = lib.mkOption {
76 type = lib.types.attrsOf (lib.types.submodule {
77 options = {
78 certName = lib.mkOption { type = lib.types.string; };
79 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
80 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
81 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
82 };
83 });
84 };
85 };
f8d3b61a
IB
86 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
87 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
88in
89{
90 imports = [
54307da4
IB
91 ./chloe
92 ./ludivine
93 ./aten
94 ./piedsjaloux
95 ./connexionswing
2f0f1c48 96 ./tellesflorian
10889174
IB
97 ./tools/db
98 ./tools/tools
99 ./tools/dav
100 ./tools/cloud
101 ./tools/git
35a397cd 102 ./tools/mastodon
56eba416 103 ./tools/mediagoblin
a7f7fdae 104 ./tools/diaspora
f8bde3d6
IB
105 # built using:
106 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 107 # Removed allGranted
f8bde3d6 108 # And removed users / groups
54307da4
IB
109 ./apache/httpd_prod.nix
110 ./apache/httpd_inte.nix
273e2c61
IB
111 # except for this one for users/groups
112 ./apache/httpd_tools.nix
10889174
IB
113 # Adapted from base phpfpm
114 ./phpfpm
42429ef0
IB
115 ];
116
117 options.services.myWebsites = {
f8bde3d6
IB
118 production = makeServiceOptions "production" myconfig.ips.production;
119 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 120 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
121
122 apacheConfig = lib.mkOption {
123 type = lib.types.attrsOf (lib.types.submodule {
124 options = {
125 modules = lib.mkOption {
126 type = lib.types.listOf (lib.types.str);
127 default = [];
128 };
129 extraConfig = lib.mkOption {
130 type = lib.types.nullOr lib.types.lines;
131 default = null;
132 };
133 };
134 });
135 default = {};
136 description = "Extra global config";
137 };
138
139 };
140
141 config = {
54307da4
IB
142 networking = {
143 firewall = {
144 enable = true;
145 allowedTCPPorts = [ 80 443 ];
146 };
147 interfaces."eth0".ipv4.addresses = [
148 # 176.9.151.89 declared in nixops -> infra / tools
149 { address = myconfig.ips.production; prefixLength = 32; }
150 { address = myconfig.ips.integration; prefixLength = 32; }
151 ];
152 };
153
98584540
IB
154 nixpkgs.config.packageOverrides = oldpkgs: rec {
155 php = php72;
156 php72 = (oldpkgs.php72.override {
157 mysql.connector-c = pkgs.mariadb;
158 config.php.mysqlnd = false;
159 config.php.mysqli = false;
160 }).overrideAttrs(old: rec {
161 # Didn't manage to build with mysqli + mysql_config connector
162 configureFlags = old.configureFlags ++ [
912921a7 163 "--with-mysqli=shared,mysqlnd"
98584540
IB
164 ];
165 # preConfigure = (old.preConfigure or "") + ''
166 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
167 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
168 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
169 # '';
170 });
171 phpPackages = oldpkgs.php72Packages.override { inherit php; };
172 };
173
10889174
IB
174 services.myWebsites.tools.databases.enable = true;
175 services.myWebsites.tools.tools.enable = true;
176 services.myWebsites.tools.dav.enable = true;
177 services.myWebsites.tools.cloud.enable = true;
178 services.myWebsites.tools.git.enable = true;
35a397cd 179 services.myWebsites.tools.mastodon.enable = true;
56eba416 180 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 181 services.myWebsites.tools.diaspora.enable = true;
10889174 182
42429ef0
IB
183 services.myWebsites.Chloe.production.enable = cfg.production.enable;
184 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
185 services.myWebsites.Aten.production.enable = cfg.production.enable;
186 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
187 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
188
189 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
190 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
191 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
192 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
193 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 194 services.myWebsites.TellesFlorian.integration.enable = true;
42429ef0
IB
195
196 services.myWebsites.apacheConfig = {
197 gzip = {
198 modules = [ "deflate" "filter" ];
199 extraConfig = ''
200 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
201 '';
202 };
203 macros = {
204 modules = [ "macro" ];
205 };
206 ldap = {
207 modules = [ "ldap" "authnz_ldap" ];
42429ef0
IB
208 extraConfig = assert mylibs.checkEnv "NIXOPS_HTTP_LDAP_PASSWORD"; ''
209 <IfModule ldap_module>
210 LDAPSharedCacheSize 500000
211 LDAPCacheEntries 1024
212 LDAPCacheTTL 600
213 LDAPOpCacheEntries 1024
214 LDAPOpCacheTTL 600
215 </IfModule>
216
217 <Macro LDAPConnect>
218 <IfModule authnz_ldap_module>
219 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
220 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
221 AuthLDAPBindPassword "${builtins.getEnv "NIXOPS_HTTP_LDAP_PASSWORD"}"
222 AuthType Basic
223 AuthName "Authentification requise (Acces LDAP)"
224 AuthBasicProvider ldap
225 </IfModule>
226 </Macro>
227
228 <Macro Stats %{domain}>
229 Alias /awstats /var/lib/goaccess/%{domain}
230 <Directory /var/lib/goaccess/%{domain}>
231 DirectoryIndex index.html
232 AllowOverride None
233 Require all granted
234 </Directory>
235 <Location /awstats>
236 Use LDAPConnect
237 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
238 </Location>
239 </Macro>
646bdf3e
IB
240
241 ErrorDocument 500 /maintenance_immae.html
242 ErrorDocument 501 /maintenance_immae.html
243 ErrorDocument 502 /maintenance_immae.html
244 ErrorDocument 503 /maintenance_immae.html
245 ErrorDocument 504 /maintenance_immae.html
246 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
247 ProxyPass /maintenance_immae.html !
248
249 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
250 '';
251 };
252 http2 = {
253 modules = [ "http2" ];
254 extraConfig = ''
255 Protocols h2 http/1.1
256 '';
257 };
258 customLog = {
259 extraConfig = ''
260 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
261 '';
262 };
263 };
f8bde3d6 264
10889174
IB
265 system.activationScripts = {
266 httpd = ''
267 install -d -m 0755 /var/lib/acme/acme-challenge
268 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
269 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
270 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
271 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
272 '';
273 };
274
275 services.myPhpfpm = {
276 phpPackage = pkgs.php;
277 phpOptions = ''
278 session.save_path = "/var/lib/php/sessions"
279 session.gc_maxlifetime = 60*60*24*15
280 session.cache_expire = 60*24*30
281 '';
282 extraConfig = ''
283 log_level = notice
284 '';
285 };
286
f8bde3d6 287 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
288 services.myWebsites.production.modules = makeModules cfg;
289 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
290
291 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
292 services.myWebsites.integration.modules = makeModules cfg;
293 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 294
273e2c61 295 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
296 services.myWebsites.tools.modules = makeModules cfg;
297 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
298 [ ''
299 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
300 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
301 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
302 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
303 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
304 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
305 ''
306 ]
307 ;
42429ef0
IB
308 };
309}