]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/default.nix
Move all fixmes to mantisbt issue tracking
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0 2let
950ca5ee
IB
3 mypkgs = pkgs.callPackage ../../packages.nix {
4 inherit (mylibs) checkEnv fetchedGit fetchedGithub;
5 };
42429ef0 6 cfg = config.services.myWebsites;
f8bde3d6
IB
7 makeService = name: cfg: let
8 toVhost = vhostConf: {
9 enableSSL = true;
10 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
11 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
12 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
13 logFormat = "combinedVhost";
14 listen = [
15 { ip = cfg.ip; port = 443; }
16 ];
17 hostName = builtins.head vhostConf.hosts;
18 serverAliases = builtins.tail vhostConf.hosts or [];
19 documentRoot = vhostConf.root;
20 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
21 };
950ca5ee
IB
22 redirectVhost = { # Should go last, catchall http -> https redirect
23 listen = [ { ip = cfg.ip; port = 80; } ];
24 hostName = "redirectSSL";
25 serverAliases = [ "*" ];
26 enableSSL = false;
27 logFormat = "combinedVhost";
28 documentRoot = "/var/lib/acme/acme-challenge";
29 extraConfig = ''
30 RewriteEngine on
31 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
32 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
33 # To redirect in specific "VirtualHost *:80", do
34 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
35 # rather than rewrite
36 '';
37 };
38 fallbackVhost = toVhost { # Should go first, default choice
39 certName = "eldiron";
40 hosts = ["eldiron.immae.eu" ];
41 root = ../../www;
42 extraConfig = [ "DirectoryIndex index.htm" ];
43 };
f8bde3d6
IB
44 in rec {
45 enable = true;
46 listen = [
47 { ip = cfg.ip; port = 443; }
48 ];
49 stateDir = "/run/httpd_${name}";
50 logPerVirtualHost = true;
51 multiProcessingModule = "worker";
52 adminAddr = "httpd@immae.eu";
53 logFormat = "combinedVhost";
54 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
55 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
56 virtualHosts = [ fallbackVhost ]
57 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
58 ++ [ redirectVhost ];
f8bde3d6
IB
59 };
60 makeServiceOptions = name: ip: {
61 enable = lib.mkEnableOption "enable websites in ${name}";
62 ip = lib.mkOption {
63 type = lib.types.string;
64 default = ip;
65 description = "${name} ip to listen to";
66 };
67 modules = lib.mkOption {
68 type = lib.types.listOf (lib.types.str);
69 default = [];
70 };
71 extraConfig = lib.mkOption {
72 type = lib.types.listOf (lib.types.lines);
73 default = [];
74 };
75 vhostConfs = lib.mkOption {
76 type = lib.types.attrsOf (lib.types.submodule {
77 options = {
78 certName = lib.mkOption { type = lib.types.string; };
79 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
80 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
81 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
82 };
83 });
84 };
85 };
42429ef0
IB
86in
87{
88 imports = [
54307da4
IB
89 ./chloe
90 ./ludivine
91 ./aten
92 ./piedsjaloux
93 ./connexionswing
2f0f1c48 94 ./tellesflorian
10889174
IB
95 ./tools/db
96 ./tools/tools
97 ./tools/dav
98 ./tools/cloud
99 ./tools/git
35a397cd 100 ./tools/mastodon
56eba416 101 ./tools/mediagoblin
a7f7fdae 102 ./tools/diaspora
f8bde3d6
IB
103 # built using:
104 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 105 # Removed allGranted
f8bde3d6 106 # And removed users / groups
54307da4
IB
107 ./apache/httpd_prod.nix
108 ./apache/httpd_inte.nix
273e2c61
IB
109 # except for this one for users/groups
110 ./apache/httpd_tools.nix
10889174
IB
111 # Adapted from base phpfpm
112 ./phpfpm
42429ef0
IB
113 ];
114
115 options.services.myWebsites = {
f8bde3d6
IB
116 production = makeServiceOptions "production" myconfig.ips.production;
117 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 118 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
119
120 apacheConfig = lib.mkOption {
121 type = lib.types.attrsOf (lib.types.submodule {
122 options = {
123 modules = lib.mkOption {
124 type = lib.types.listOf (lib.types.str);
125 default = [];
126 };
127 extraConfig = lib.mkOption {
128 type = lib.types.nullOr lib.types.lines;
129 default = null;
130 };
131 };
132 });
133 default = {};
134 description = "Extra global config";
135 };
136
137 };
138
139 config = {
54307da4
IB
140 networking = {
141 firewall = {
142 enable = true;
143 allowedTCPPorts = [ 80 443 ];
144 };
145 interfaces."eth0".ipv4.addresses = [
146 # 176.9.151.89 declared in nixops -> infra / tools
147 { address = myconfig.ips.production; prefixLength = 32; }
148 { address = myconfig.ips.integration; prefixLength = 32; }
149 ];
150 };
151
98584540
IB
152 nixpkgs.config.packageOverrides = oldpkgs: rec {
153 php = php72;
154 php72 = (oldpkgs.php72.override {
155 mysql.connector-c = pkgs.mariadb;
156 config.php.mysqlnd = false;
157 config.php.mysqli = false;
158 }).overrideAttrs(old: rec {
159 # Didn't manage to build with mysqli + mysql_config connector
160 configureFlags = old.configureFlags ++ [
912921a7 161 "--with-mysqli=shared,mysqlnd"
98584540
IB
162 ];
163 # preConfigure = (old.preConfigure or "") + ''
164 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
165 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
166 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
167 # '';
168 });
169 phpPackages = oldpkgs.php72Packages.override { inherit php; };
170 };
171
10889174
IB
172 services.myWebsites.tools.databases.enable = true;
173 services.myWebsites.tools.tools.enable = true;
174 services.myWebsites.tools.dav.enable = true;
175 services.myWebsites.tools.cloud.enable = true;
176 services.myWebsites.tools.git.enable = true;
35a397cd 177 services.myWebsites.tools.mastodon.enable = true;
56eba416 178 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 179 services.myWebsites.tools.diaspora.enable = true;
10889174 180
42429ef0
IB
181 services.myWebsites.Chloe.production.enable = cfg.production.enable;
182 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
183 services.myWebsites.Aten.production.enable = cfg.production.enable;
184 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
185 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
186
187 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
188 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
189 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
190 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
191 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 192 services.myWebsites.TellesFlorian.integration.enable = true;
42429ef0
IB
193
194 services.myWebsites.apacheConfig = {
195 gzip = {
196 modules = [ "deflate" "filter" ];
197 extraConfig = ''
198 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
199 '';
200 };
201 macros = {
202 modules = [ "macro" ];
203 };
204 ldap = {
205 modules = [ "ldap" "authnz_ldap" ];
42429ef0
IB
206 extraConfig = assert mylibs.checkEnv "NIXOPS_HTTP_LDAP_PASSWORD"; ''
207 <IfModule ldap_module>
208 LDAPSharedCacheSize 500000
209 LDAPCacheEntries 1024
210 LDAPCacheTTL 600
211 LDAPOpCacheEntries 1024
212 LDAPOpCacheTTL 600
213 </IfModule>
214
215 <Macro LDAPConnect>
216 <IfModule authnz_ldap_module>
217 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
218 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
219 AuthLDAPBindPassword "${builtins.getEnv "NIXOPS_HTTP_LDAP_PASSWORD"}"
220 AuthType Basic
221 AuthName "Authentification requise (Acces LDAP)"
222 AuthBasicProvider ldap
223 </IfModule>
224 </Macro>
225
226 <Macro Stats %{domain}>
227 Alias /awstats /var/lib/goaccess/%{domain}
228 <Directory /var/lib/goaccess/%{domain}>
229 DirectoryIndex index.html
230 AllowOverride None
231 Require all granted
232 </Directory>
233 <Location /awstats>
234 Use LDAPConnect
235 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
236 </Location>
237 </Macro>
646bdf3e
IB
238
239 ErrorDocument 500 /maintenance_immae.html
240 ErrorDocument 501 /maintenance_immae.html
241 ErrorDocument 502 /maintenance_immae.html
242 ErrorDocument 503 /maintenance_immae.html
243 ErrorDocument 504 /maintenance_immae.html
244 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
245 ProxyPass /maintenance_immae.html !
246
247 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
248 '';
249 };
250 http2 = {
251 modules = [ "http2" ];
252 extraConfig = ''
253 Protocols h2 http/1.1
254 '';
255 };
256 customLog = {
257 extraConfig = ''
258 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
259 '';
260 };
261 };
f8bde3d6 262
10889174
IB
263 system.activationScripts = {
264 httpd = ''
265 install -d -m 0755 /var/lib/acme/acme-challenge
266 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
267 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
268 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
269 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
270 '';
271 };
272
273 services.myPhpfpm = {
274 phpPackage = pkgs.php;
275 phpOptions = ''
276 session.save_path = "/var/lib/php/sessions"
277 session.gc_maxlifetime = 60*60*24*15
278 session.cache_expire = 60*24*30
279 '';
280 extraConfig = ''
281 log_level = notice
282 '';
283 };
284
f8bde3d6
IB
285 services.httpdProd = makeService "production" config.services.myWebsites.production;
286 services.myWebsites.production.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
287 services.myWebsites.production.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
288
289 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
290 services.myWebsites.integration.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
291 services.myWebsites.integration.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
950ca5ee 292
273e2c61 293 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
10889174 294 services.myWebsites.tools.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
646bdf3e
IB
295 services.myWebsites.tools.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig)) ++
296 [ ''
297 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
298 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
299 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
300 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
301 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
302 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
303 ''
304 ]
305 ;
42429ef0
IB
306 };
307}