]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/default.nix
Add capitaines mastodon pages
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
f8bde3d6
IB
4 makeService = name: cfg: let
5 toVhost = vhostConf: {
6 enableSSL = true;
7 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
8 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
9 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
10 logFormat = "combinedVhost";
11 listen = [
12 { ip = cfg.ip; port = 443; }
13 ];
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
950ca5ee
IB
19 redirectVhost = { # Should go last, catchall http -> https redirect
20 listen = [ { ip = cfg.ip; port = 80; } ];
21 hostName = "redirectSSL";
22 serverAliases = [ "*" ];
23 enableSSL = false;
24 logFormat = "combinedVhost";
25 documentRoot = "/var/lib/acme/acme-challenge";
26 extraConfig = ''
27 RewriteEngine on
28 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
29 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
30 # To redirect in specific "VirtualHost *:80", do
31 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
32 # rather than rewrite
33 '';
34 };
35 fallbackVhost = toVhost { # Should go first, default choice
36 certName = "eldiron";
37 hosts = ["eldiron.immae.eu" ];
38 root = ../../www;
39 extraConfig = [ "DirectoryIndex index.htm" ];
40 };
f8bde3d6
IB
41 in rec {
42 enable = true;
43 listen = [
44 { ip = cfg.ip; port = 443; }
45 ];
46 stateDir = "/run/httpd_${name}";
47 logPerVirtualHost = true;
48 multiProcessingModule = "worker";
49 adminAddr = "httpd@immae.eu";
50 logFormat = "combinedVhost";
51 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
52 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
53 virtualHosts = [ fallbackVhost ]
54 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
55 ++ [ redirectVhost ];
f8bde3d6
IB
56 };
57 makeServiceOptions = name: ip: {
58 enable = lib.mkEnableOption "enable websites in ${name}";
59 ip = lib.mkOption {
60 type = lib.types.string;
61 default = ip;
62 description = "${name} ip to listen to";
63 };
64 modules = lib.mkOption {
65 type = lib.types.listOf (lib.types.str);
66 default = [];
67 };
68 extraConfig = lib.mkOption {
69 type = lib.types.listOf (lib.types.lines);
70 default = [];
71 };
72 vhostConfs = lib.mkOption {
73 type = lib.types.attrsOf (lib.types.submodule {
74 options = {
75 certName = lib.mkOption { type = lib.types.string; };
76 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
77 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
78 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
79 };
80 });
81 };
82 };
f8d3b61a
IB
83 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
84 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
85in
86{
87 imports = [
54307da4
IB
88 ./chloe
89 ./ludivine
90 ./aten
91 ./piedsjaloux
92 ./connexionswing
2f0f1c48 93 ./tellesflorian
9a35b8f9 94 ./emilia
10bd8c08 95 ./capitaines
d578d270 96 ./ftp/jerome.nix
53b8fad9 97 ./ftp/nassime.nix
79f239be 98 ./ftp/florian.nix
dc9fb826 99 ./ftp/denisejerome.nix
10889174
IB
100 ./tools/db
101 ./tools/tools
102 ./tools/dav
103 ./tools/cloud
104 ./tools/git
35a397cd 105 ./tools/mastodon
56eba416 106 ./tools/mediagoblin
a7f7fdae 107 ./tools/diaspora
17146204 108 ./tools/ether
f8bde3d6
IB
109 # built using:
110 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 111 # Removed allGranted
f8bde3d6 112 # And removed users / groups
54307da4
IB
113 ./apache/httpd_prod.nix
114 ./apache/httpd_inte.nix
273e2c61
IB
115 # except for this one for users/groups
116 ./apache/httpd_tools.nix
10889174
IB
117 # Adapted from base phpfpm
118 ./phpfpm
42429ef0
IB
119 ];
120
121 options.services.myWebsites = {
f8bde3d6
IB
122 production = makeServiceOptions "production" myconfig.ips.production;
123 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 124 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
125
126 apacheConfig = lib.mkOption {
127 type = lib.types.attrsOf (lib.types.submodule {
128 options = {
129 modules = lib.mkOption {
130 type = lib.types.listOf (lib.types.str);
131 default = [];
132 };
133 extraConfig = lib.mkOption {
134 type = lib.types.nullOr lib.types.lines;
135 default = null;
136 };
137 };
138 });
139 default = {};
140 description = "Extra global config";
141 };
142
143 };
144
145 config = {
54307da4
IB
146 networking = {
147 firewall = {
148 enable = true;
149 allowedTCPPorts = [ 80 443 ];
150 };
151 interfaces."eth0".ipv4.addresses = [
152 # 176.9.151.89 declared in nixops -> infra / tools
153 { address = myconfig.ips.production; prefixLength = 32; }
154 { address = myconfig.ips.integration; prefixLength = 32; }
155 ];
156 };
157
98584540
IB
158 nixpkgs.config.packageOverrides = oldpkgs: rec {
159 php = php72;
160 php72 = (oldpkgs.php72.override {
161 mysql.connector-c = pkgs.mariadb;
162 config.php.mysqlnd = false;
163 config.php.mysqli = false;
164 }).overrideAttrs(old: rec {
165 # Didn't manage to build with mysqli + mysql_config connector
166 configureFlags = old.configureFlags ++ [
912921a7 167 "--with-mysqli=shared,mysqlnd"
98584540
IB
168 ];
169 # preConfigure = (old.preConfigure or "") + ''
170 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
171 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
172 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
173 # '';
174 });
175 phpPackages = oldpkgs.php72Packages.override { inherit php; };
d78128ec
IB
176 composerEnv = import ./commons/composer-env.nix {
177 inherit (pkgs) stdenv writeTextFile fetchurl php unzip;
178 };
98584540
IB
179 };
180
10889174
IB
181 services.myWebsites.tools.databases.enable = true;
182 services.myWebsites.tools.tools.enable = true;
183 services.myWebsites.tools.dav.enable = true;
184 services.myWebsites.tools.cloud.enable = true;
185 services.myWebsites.tools.git.enable = true;
35a397cd 186 services.myWebsites.tools.mastodon.enable = true;
56eba416 187 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 188 services.myWebsites.tools.diaspora.enable = true;
17146204 189 services.myWebsites.tools.etherpad-lite.enable = true;
10889174 190
42429ef0
IB
191 services.myWebsites.Chloe.production.enable = cfg.production.enable;
192 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
193 services.myWebsites.Aten.production.enable = cfg.production.enable;
194 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
195 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
d578d270 196 services.myWebsites.Jerome.production.enable = cfg.production.enable;
53b8fad9 197 services.myWebsites.Nassime.production.enable = cfg.production.enable;
79f239be 198 services.myWebsites.Florian.production.enable = cfg.production.enable;
dc9fb826 199 services.myWebsites.DeniseJerome.production.enable = cfg.production.enable;
9a35b8f9 200 services.myWebsites.Emilia.production.enable = cfg.production.enable;
10bd8c08 201 services.myWebsites.Capitaines.production.enable = cfg.production.enable;
42429ef0
IB
202
203 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
204 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
205 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
206 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
207 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 208 services.myWebsites.TellesFlorian.integration.enable = true;
79f239be 209 services.myWebsites.Florian.integration.enable = true;
42429ef0
IB
210
211 services.myWebsites.apacheConfig = {
212 gzip = {
213 modules = [ "deflate" "filter" ];
214 extraConfig = ''
215 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
216 '';
217 };
218 macros = {
219 modules = [ "macro" ];
220 };
221 ldap = {
222 modules = [ "ldap" "authnz_ldap" ];
9d90e7e2 223 extraConfig = ''
42429ef0
IB
224 <IfModule ldap_module>
225 LDAPSharedCacheSize 500000
226 LDAPCacheEntries 1024
227 LDAPCacheTTL 600
228 LDAPOpCacheEntries 1024
229 LDAPOpCacheTTL 600
230 </IfModule>
231
232 <Macro LDAPConnect>
233 <IfModule authnz_ldap_module>
234 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
235 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
9d90e7e2 236 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
42429ef0
IB
237 AuthType Basic
238 AuthName "Authentification requise (Acces LDAP)"
239 AuthBasicProvider ldap
240 </IfModule>
241 </Macro>
242
243 <Macro Stats %{domain}>
244 Alias /awstats /var/lib/goaccess/%{domain}
245 <Directory /var/lib/goaccess/%{domain}>
246 DirectoryIndex index.html
247 AllowOverride None
248 Require all granted
249 </Directory>
250 <Location /awstats>
251 Use LDAPConnect
252 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
253 </Location>
254 </Macro>
646bdf3e
IB
255
256 ErrorDocument 500 /maintenance_immae.html
257 ErrorDocument 501 /maintenance_immae.html
258 ErrorDocument 502 /maintenance_immae.html
259 ErrorDocument 503 /maintenance_immae.html
260 ErrorDocument 504 /maintenance_immae.html
261 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
262 ProxyPass /maintenance_immae.html !
263
264 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
265 '';
266 };
267 http2 = {
268 modules = [ "http2" ];
269 extraConfig = ''
270 Protocols h2 http/1.1
271 '';
272 };
273 customLog = {
274 extraConfig = ''
275 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
276 '';
277 };
278 };
f8bde3d6 279
10889174
IB
280 system.activationScripts = {
281 httpd = ''
282 install -d -m 0755 /var/lib/acme/acme-challenge
283 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
284 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
285 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
286 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
287 '';
288 };
289
290 services.myPhpfpm = {
291 phpPackage = pkgs.php;
292 phpOptions = ''
293 session.save_path = "/var/lib/php/sessions"
294 session.gc_maxlifetime = 60*60*24*15
295 session.cache_expire = 60*24*30
296 '';
297 extraConfig = ''
298 log_level = notice
299 '';
300 };
301
f8bde3d6 302 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
303 services.myWebsites.production.modules = makeModules cfg;
304 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
305
306 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
307 services.myWebsites.integration.modules = makeModules cfg;
308 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 309
273e2c61 310 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
311 services.myWebsites.tools.modules = makeModules cfg;
312 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
313 [ ''
314 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
315 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
316 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
317 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
318 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
319 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
320 ''
321 ]
322 ;
42429ef0
IB
323 };
324}