]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/default.nix
Add Nassime's website
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
CommitLineData
f8bde3d6 1{ lib, pkgs, config, mylibs, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
f8bde3d6
IB
4 makeService = name: cfg: let
5 toVhost = vhostConf: {
6 enableSSL = true;
7 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
8 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
9 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
10 logFormat = "combinedVhost";
11 listen = [
12 { ip = cfg.ip; port = 443; }
13 ];
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
950ca5ee
IB
19 redirectVhost = { # Should go last, catchall http -> https redirect
20 listen = [ { ip = cfg.ip; port = 80; } ];
21 hostName = "redirectSSL";
22 serverAliases = [ "*" ];
23 enableSSL = false;
24 logFormat = "combinedVhost";
25 documentRoot = "/var/lib/acme/acme-challenge";
26 extraConfig = ''
27 RewriteEngine on
28 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
29 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
30 # To redirect in specific "VirtualHost *:80", do
31 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
32 # rather than rewrite
33 '';
34 };
35 fallbackVhost = toVhost { # Should go first, default choice
36 certName = "eldiron";
37 hosts = ["eldiron.immae.eu" ];
38 root = ../../www;
39 extraConfig = [ "DirectoryIndex index.htm" ];
40 };
f8bde3d6
IB
41 in rec {
42 enable = true;
43 listen = [
44 { ip = cfg.ip; port = 443; }
45 ];
46 stateDir = "/run/httpd_${name}";
47 logPerVirtualHost = true;
48 multiProcessingModule = "worker";
49 adminAddr = "httpd@immae.eu";
50 logFormat = "combinedVhost";
51 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
52 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
950ca5ee
IB
53 virtualHosts = [ fallbackVhost ]
54 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
55 ++ [ redirectVhost ];
f8bde3d6
IB
56 };
57 makeServiceOptions = name: ip: {
58 enable = lib.mkEnableOption "enable websites in ${name}";
59 ip = lib.mkOption {
60 type = lib.types.string;
61 default = ip;
62 description = "${name} ip to listen to";
63 };
64 modules = lib.mkOption {
65 type = lib.types.listOf (lib.types.str);
66 default = [];
67 };
68 extraConfig = lib.mkOption {
69 type = lib.types.listOf (lib.types.lines);
70 default = [];
71 };
72 vhostConfs = lib.mkOption {
73 type = lib.types.attrsOf (lib.types.submodule {
74 options = {
75 certName = lib.mkOption { type = lib.types.string; };
76 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
77 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
78 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
79 };
80 });
81 };
82 };
f8d3b61a
IB
83 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
84 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
42429ef0
IB
85in
86{
87 imports = [
54307da4
IB
88 ./chloe
89 ./ludivine
90 ./aten
91 ./piedsjaloux
92 ./connexionswing
2f0f1c48 93 ./tellesflorian
d578d270 94 ./ftp/jerome.nix
53b8fad9 95 ./ftp/nassime.nix
10889174
IB
96 ./tools/db
97 ./tools/tools
98 ./tools/dav
99 ./tools/cloud
100 ./tools/git
35a397cd 101 ./tools/mastodon
56eba416 102 ./tools/mediagoblin
a7f7fdae 103 ./tools/diaspora
17146204 104 ./tools/ether
f8bde3d6
IB
105 # built using:
106 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
273e2c61 107 # Removed allGranted
f8bde3d6 108 # And removed users / groups
54307da4
IB
109 ./apache/httpd_prod.nix
110 ./apache/httpd_inte.nix
273e2c61
IB
111 # except for this one for users/groups
112 ./apache/httpd_tools.nix
10889174
IB
113 # Adapted from base phpfpm
114 ./phpfpm
42429ef0
IB
115 ];
116
117 options.services.myWebsites = {
f8bde3d6
IB
118 production = makeServiceOptions "production" myconfig.ips.production;
119 integration = makeServiceOptions "integration" myconfig.ips.integration;
950ca5ee 120 tools = makeServiceOptions "tools" myconfig.ips.main;
42429ef0
IB
121
122 apacheConfig = lib.mkOption {
123 type = lib.types.attrsOf (lib.types.submodule {
124 options = {
125 modules = lib.mkOption {
126 type = lib.types.listOf (lib.types.str);
127 default = [];
128 };
129 extraConfig = lib.mkOption {
130 type = lib.types.nullOr lib.types.lines;
131 default = null;
132 };
133 };
134 });
135 default = {};
136 description = "Extra global config";
137 };
138
139 };
140
141 config = {
54307da4
IB
142 networking = {
143 firewall = {
144 enable = true;
145 allowedTCPPorts = [ 80 443 ];
146 };
147 interfaces."eth0".ipv4.addresses = [
148 # 176.9.151.89 declared in nixops -> infra / tools
149 { address = myconfig.ips.production; prefixLength = 32; }
150 { address = myconfig.ips.integration; prefixLength = 32; }
151 ];
152 };
153
98584540
IB
154 nixpkgs.config.packageOverrides = oldpkgs: rec {
155 php = php72;
156 php72 = (oldpkgs.php72.override {
157 mysql.connector-c = pkgs.mariadb;
158 config.php.mysqlnd = false;
159 config.php.mysqli = false;
160 }).overrideAttrs(old: rec {
161 # Didn't manage to build with mysqli + mysql_config connector
162 configureFlags = old.configureFlags ++ [
912921a7 163 "--with-mysqli=shared,mysqlnd"
98584540
IB
164 ];
165 # preConfigure = (old.preConfigure or "") + ''
166 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
167 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
168 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
169 # '';
170 });
171 phpPackages = oldpkgs.php72Packages.override { inherit php; };
d78128ec
IB
172 composerEnv = import ./commons/composer-env.nix {
173 inherit (pkgs) stdenv writeTextFile fetchurl php unzip;
174 };
98584540
IB
175 };
176
10889174
IB
177 services.myWebsites.tools.databases.enable = true;
178 services.myWebsites.tools.tools.enable = true;
179 services.myWebsites.tools.dav.enable = true;
180 services.myWebsites.tools.cloud.enable = true;
181 services.myWebsites.tools.git.enable = true;
35a397cd 182 services.myWebsites.tools.mastodon.enable = true;
56eba416 183 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 184 services.myWebsites.tools.diaspora.enable = true;
17146204 185 services.myWebsites.tools.etherpad-lite.enable = true;
10889174 186
42429ef0
IB
187 services.myWebsites.Chloe.production.enable = cfg.production.enable;
188 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
189 services.myWebsites.Aten.production.enable = cfg.production.enable;
190 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
191 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
d578d270 192 services.myWebsites.Jerome.production.enable = cfg.production.enable;
53b8fad9 193 services.myWebsites.Nassime.production.enable = cfg.production.enable;
42429ef0
IB
194
195 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
196 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
197 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
198 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
199 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
2f0f1c48 200 services.myWebsites.TellesFlorian.integration.enable = true;
42429ef0
IB
201
202 services.myWebsites.apacheConfig = {
203 gzip = {
204 modules = [ "deflate" "filter" ];
205 extraConfig = ''
206 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
207 '';
208 };
209 macros = {
210 modules = [ "macro" ];
211 };
212 ldap = {
213 modules = [ "ldap" "authnz_ldap" ];
9d90e7e2 214 extraConfig = ''
42429ef0
IB
215 <IfModule ldap_module>
216 LDAPSharedCacheSize 500000
217 LDAPCacheEntries 1024
218 LDAPCacheTTL 600
219 LDAPOpCacheEntries 1024
220 LDAPOpCacheTTL 600
221 </IfModule>
222
223 <Macro LDAPConnect>
224 <IfModule authnz_ldap_module>
225 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
226 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
9d90e7e2 227 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
42429ef0
IB
228 AuthType Basic
229 AuthName "Authentification requise (Acces LDAP)"
230 AuthBasicProvider ldap
231 </IfModule>
232 </Macro>
233
234 <Macro Stats %{domain}>
235 Alias /awstats /var/lib/goaccess/%{domain}
236 <Directory /var/lib/goaccess/%{domain}>
237 DirectoryIndex index.html
238 AllowOverride None
239 Require all granted
240 </Directory>
241 <Location /awstats>
242 Use LDAPConnect
243 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
244 </Location>
245 </Macro>
646bdf3e
IB
246
247 ErrorDocument 500 /maintenance_immae.html
248 ErrorDocument 501 /maintenance_immae.html
249 ErrorDocument 502 /maintenance_immae.html
250 ErrorDocument 503 /maintenance_immae.html
251 ErrorDocument 504 /maintenance_immae.html
252 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
253 ProxyPass /maintenance_immae.html !
254
255 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
42429ef0
IB
256 '';
257 };
258 http2 = {
259 modules = [ "http2" ];
260 extraConfig = ''
261 Protocols h2 http/1.1
262 '';
263 };
264 customLog = {
265 extraConfig = ''
266 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
267 '';
268 };
269 };
f8bde3d6 270
10889174
IB
271 system.activationScripts = {
272 httpd = ''
273 install -d -m 0755 /var/lib/acme/acme-challenge
274 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
275 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
276 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
277 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
278 '';
279 };
280
281 services.myPhpfpm = {
282 phpPackage = pkgs.php;
283 phpOptions = ''
284 session.save_path = "/var/lib/php/sessions"
285 session.gc_maxlifetime = 60*60*24*15
286 session.cache_expire = 60*24*30
287 '';
288 extraConfig = ''
289 log_level = notice
290 '';
291 };
292
f8bde3d6 293 services.httpdProd = makeService "production" config.services.myWebsites.production;
f8d3b61a
IB
294 services.myWebsites.production.modules = makeModules cfg;
295 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
f8bde3d6
IB
296
297 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
f8d3b61a
IB
298 services.myWebsites.integration.modules = makeModules cfg;
299 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
950ca5ee 300
273e2c61 301 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
f8d3b61a
IB
302 services.myWebsites.tools.modules = makeModules cfg;
303 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
646bdf3e
IB
304 [ ''
305 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
306 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
307 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
308 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
309 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
310 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
311 ''
312 ]
313 ;
42429ef0
IB
314 };
315}