]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blame - music_sampler.spec
Put time duration in playlist
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
CommitLineData
d8ab67c7 1# -*- mode: python -*-
d8046b94 2from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal, hookspath, runtime_hooks
d8ab67c7 3
d8046b94
IB
4excluded_and_hidden_modules = get_deps_minimal(video=None, camera=None, audio=None, clipboard=None, spelling=None)
5excluded_and_hidden_modules['hiddenimports'] += [ 'six', 'packaging', 'packaging.version', 'packaging.specifiers', 'packaging.requirements']
d8ab67c7 6
532454eb 7a = Analysis(['music_sampler.py'],
d8ab67c7 8 binaries=None,
9de92b6d 9 datas=[
bb69f62e 10 ('fonts/*', 'fonts'),
e4846541 11 ('music_sampler.kv', '.')
9de92b6d 12 ],
d8046b94
IB
13 hookspath=hookspath(),
14 runtime_hooks=runtime_hooks(),
15 **excluded_and_hidden_modules)
16pyz = PYZ(a.pure, a.zipped_data)
17exe = EXE(pyz, a.scripts, a.binaries, a.zipfiles, a.datas, name='music_sampler')