]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blame - music_sampler.spec
Make kivy compatible with pyinstaller
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
CommitLineData
d8ab67c7
IB
1# -*- mode: python -*-
2
3block_cipher = None
4
532454eb 5a = Analysis(['music_sampler.py'],
d8ab67c7 6 binaries=None,
9de92b6d
IB
7 datas=[
8 ('config.yml', '.'),
bb69f62e
IB
9 ('fonts/*', 'fonts'),
10 ('musicsampler.kv', '.')
9de92b6d 11 ],
d8ab67c7
IB
12 hiddenimports=[
13 'six',
14 'packaging',
15 'packaging.version',
16 'packaging.specifiers',
17 'packaging.requirements'
18 ],
19 hookspath=[],
20 runtime_hooks=[],
21 excludes=[],
22 win_no_prefer_redirects=False,
23 win_private_assemblies=False,
24 cipher=block_cipher)
25pyz = PYZ(a.pure, a.zipped_data,
26 cipher=block_cipher)
27exe = EXE(pyz,
28 a.scripts,
29 a.binaries,
30 a.zipfiles,
31 a.datas,
532454eb 32 name='music_sampler',
d8ab67c7
IB
33 debug=False,
34 strip=False,
35 upx=True,
36 console=True )