]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - pkgs/simp_le/default.nix
Upgrade acme bot
[perso/Immae/Config/Nix/NUR.git] / pkgs / simp_le / default.nix
1 { stdenv, python3Packages, bash }:
2
3 python3Packages.buildPythonApplication rec {
4 pname = "simp_le-client";
5 version = "0.17.0";
6
7 src = python3Packages.fetchPypi {
8 inherit pname version;
9 sha256 = "0m1jynar4calaffp2zdxr5yy9vnhw2qf2hsfxwzfwf8fqb5h7bjb";
10 };
11
12 postPatch = ''
13 # drop upper bound of idna requirement
14 sed -ri "s/'(idna)<[^']+'/'\1'/" setup.py
15 substituteInPlace simp_le.py \
16 --replace "/bin/sh" "${bash}/bin/sh"
17 '';
18
19 checkPhase = ''
20 $out/bin/simp_le --test
21 '';
22
23 propagatedBuildInputs = with python3Packages; [ acme setuptools_scm josepy idna ];
24
25 meta = with stdenv.lib; {
26 homepage = https://github.com/zenhack/simp_le;
27 description = "Simple Let's Encrypt client";
28 license = licenses.gpl3;
29 maintainers = with maintainers; [ gebner makefu ];
30 platforms = platforms.linux;
31 };
32 }