]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame - pkgs/terminal-velocity/default.nix
Use fetchgit rather than builtins
[perso/Immae/Config/Nix/NUR.git] / pkgs / terminal-velocity / default.nix
CommitLineData
24fd1fe6
IB
1{ python36Packages }:
2with python36Packages;
3buildPythonApplication rec {
4 pname = "terminal-velocity-git";
5 version = "0.2.0";
6 src = fetchPypi {
7 inherit pname version;
8 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
9 };
10
11 patches = [
12 ./sort_found_notes.patch
13 ./python3_support.patch
14 # FIXME: update this patch when version changes
15 ./fix_build.patch
16 ];
17
2bcc666f
IB
18 preCheck = ''
19 # Needed for urwid test
20 export LC_ALL=en_US.UTF-8
21 '';
24fd1fe6
IB
22 propagatedBuildInputs = [
23 chardet
24 urwid
25 (sh.overridePythonAttrs { doCheck = false; })
26 pyyaml
27 ];
28 buildInputs = [
29 m2r
30 (restructuredtext_lint.overridePythonAttrs { doCheck = false; })
31 pygments
32 ];
33
34 postInstall = ''
35 rm $out/bin/terminal_velocity
36 '';
37}