]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame - pkgs/default.nix
Use fetchgit rather than builtins
[perso/Immae/Config/Nix/NUR.git] / pkgs / default.nix
CommitLineData
24fd1fe6
IB
1{ pkgs }:
2with pkgs;
3let
13248445 4 mylibs = import ../lib { inherit pkgs; };
24fd1fe6
IB
5in
6rec {
a1cb06e4 7 sources = import ../nix/sources.nix;
eaa9613a 8 myEnvironments = callPackage ../environments {};
a1cb06e4
IB
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
11 duply = callPackage ./duply {};
12 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
13 genius = callPackage ./genius {};
14 mtop = callPackage ./mtop {};
15 muttprint = callPackage ./muttprint {};
16 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
17 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
18 nagnu = callPackage ./nagnu { inherit mylibs; };
19 note = callPackage ./note {};
20 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
21 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
22 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
23 openarc = callPackage ./openarc { inherit mylibs; };
24 opendmarc = callPackage ./opendmarc { libspf2 = callPackage ./opendmarc/libspf2.nix {}; };
25 pg_activity = callPackage ./pg_activity { inherit mylibs; };
26 pgloader = callPackage ./pgloader {};
27 predixy = callPackage ./predixy { inherit mylibs; };
28 rrsync_sudo = callPackage ./rrsync_sudo {};
29 telegram-cli = callPackage ./telegram-cli { inherit mylibs; };
30 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
31 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
32 terminal-velocity = callPackage ./terminal-velocity {};
33 tiv = callPackage ./tiv {};
34 unicodeDoc = callPackage ./unicode {};
24fd1fe6 35
a1cb06e4
IB
36 cardano = callPackage ./crypto/cardano { inherit mylibs; };
37 cardano-cli = callPackage ./crypto/cardano-cli {};
38 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
39 sia = callPackage ./crypto/sia {};
24fd1fe6 40
a1cb06e4
IB
41 pure-ftpd = callPackage ./pure-ftpd {};
42 mpd = (callPackage ./mpd_0_21 {}).mpd;
43 mpd-small = (callPackage ./mpd_0_21 {}).mpd-small;
24fd1fe6
IB
44
45 bitlbee-mastodon = callPackage ./bitlbee-mastodon {};
46
47 composerEnv = callPackage ./composer-env {};
5ea02e51 48 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
24fd1fe6 49
17eabf47
IB
50 monitoring-plugins = callPackage ./monitoring-plugins {};
51 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
52 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
53
24fd1fe6
IB
54 python3PackagesPlus = callPackage ./python-packages {
55 python = python3;
56 inherit mylibs;
57 };
72844d53
IB
58 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
59 inherit mylibs;
60 };
61 dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
62 inherit mylibs;
63 };
c566184e 64
db85e40f 65 fiche = callPackage ./fiche { inherit mylibs; };
24fd1fe6 66}