]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - overlays/environments/immae-eu.nix
Add new machine to nixops
[perso/Immae/Config/Nix.git] / overlays / environments / immae-eu.nix
CommitLineData
fdf6f74d
IB
1self: super: with self;
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano sia monero
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
e96787f1 26 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
36
37 # git
5304a64b 38 vcsh gitRepo gitAndTools.stgit tig ripgrep
fdf6f74d
IB
39
40 # graphical tools
41 nextcloud-client firefox
42 dwm dmenu st
43
44 # images
054a2da2 45 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
46
47 # internet browsing
48 w3m lynx links elinks browsh weboob urlview googler urlwatch
49
50 # less
51 python3Packages.pygments lesspipe highlight sourceHighlight
52
53 # monitoring
54 cnagios mtop pg_activity nagios-cli mtr
054a2da2 55 iftop htop iotop iperf bonfire
fdf6f74d
IB
56 goaccess
57 # nagnu
58
59 # messaging/forums/news
60 flrn slrn
61 telegram-cli telegram-history-dump telegramircd
62 weechat profanity
63 newsboat irssi
64
65 # nix
8415083e 66 mylibs.yarn2nixPackage.yarn2nix nix
fdf6f74d
IB
67 nixops nix-prefetch-scripts nix-generate-from-cpan
68 nix-zsh-completions bundix nodePackages.bower2nix
803d2d9f 69 nodePackages.node2nix
fdf6f74d
IB
70 # (nixos {}).nixos-generate-config
71 # (nixos {}).nixos-install
72 # (nixos {}).nixos-enter
73 # (nixos {}).manual.manpages
74
75 # note taking
76 note terminal-velocity jrnl
77
78 # office
79 sc-im ranger
80 genius bc
81 ledger
82 tmux
83 rtorrent
84 ldapvi
054a2da2 85 fzf
099ab5fe 86 buku
fdf6f74d
IB
87
88 # password management
89 pass apg pwgen
90
91 # pdf
92 pdftk poppler_utils
93
94 # programming
95 pelican emacs26-nox ctags
e820fa7d 96 wdiff
fdf6f74d
IB
97
98 # security
99 keybase
100
101 # todolist/time management
102 taskwarrior vit timewarrior
103
104 # video/music
105 youtube-dl ncmpc ncmpcpp ffmpeg
106
b8951433
IB
107 # s6 tools (part of skawarePackages)
108 skalibs execline s6 s6-dns s6-linux-utils s6-networking
109 s6-portable-utils
110
fdf6f74d 111 # other tools
5304a64b 112 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
e886ea19
IB
113
114 # Terraform + AWS
115 terraform_0_12 awscli
116 (ansible.override { python2 = python3; }) python3Packages.boto
117 openvpn
fdf6f74d
IB
118 ];
119in
120{
121 myEnvironments.immae-eu = buildEnv {
122 name = "immae-eu-packages";
123 inherit paths;
124 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
125 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
126 };
127}