]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - overlays/environments/immae-eu.nix
Refactor configuration and overlays
[perso/Immae/Config/Nix.git] / overlays / environments / immae-eu.nix
CommitLineData
fdf6f74d
IB
1self: super: with self;
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano sia monero
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
36
37 # git
38 vcsh gitRepo gitAndTools.stgit tig
39
40 # graphical tools
41 nextcloud-client firefox
42 dwm dmenu st
43
44 # images
45 feh imagemagick tiv graphicsmagick
46
47 # internet browsing
48 w3m lynx links elinks browsh weboob urlview googler urlwatch
49
50 # less
51 python3Packages.pygments lesspipe highlight sourceHighlight
52
53 # monitoring
54 cnagios mtop pg_activity nagios-cli mtr
55 iftop htop iotop iperf
56 goaccess
57 # nagnu
58
59 # messaging/forums/news
60 flrn slrn
61 telegram-cli telegram-history-dump telegramircd
62 weechat profanity
63 newsboat irssi
64
65 # nix
66 mylibs.yarn2nixPackage.yarn2nix
67 nixops nix-prefetch-scripts nix-generate-from-cpan
68 nix-zsh-completions bundix nodePackages.bower2nix
69 # (nixos {}).nixos-generate-config
70 # (nixos {}).nixos-install
71 # (nixos {}).nixos-enter
72 # (nixos {}).manual.manpages
73
74 # note taking
75 note terminal-velocity jrnl
76
77 # office
78 sc-im ranger
79 genius bc
80 ledger
81 tmux
82 rtorrent
83 ldapvi
84
85 # password management
86 pass apg pwgen
87
88 # pdf
89 pdftk poppler_utils
90
91 # programming
92 pelican emacs26-nox ctags
93
94 # security
95 keybase
96
97 # todolist/time management
98 taskwarrior vit timewarrior
99
100 # video/music
101 youtube-dl ncmpc ncmpcpp ffmpeg
102
103 # other tools
104 pgloader s3cmd lftp jq cpulimit libxslt
105 ];
106in
107{
108 myEnvironments.immae-eu = buildEnv {
109 name = "immae-eu-packages";
110 inherit paths;
111 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
112 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
113 };
114}