]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - overlays/environments/immae-eu.nix
Add some tools in environment
[perso/Immae/Config/Nix.git] / overlays / environments / immae-eu.nix
CommitLineData
fdf6f74d
IB
1self: super: with self;
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano sia monero
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
e96787f1 26 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
36
37 # git
38 vcsh gitRepo gitAndTools.stgit tig
39
40 # graphical tools
41 nextcloud-client firefox
42 dwm dmenu st
43
44 # images
054a2da2 45 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
46
47 # internet browsing
48 w3m lynx links elinks browsh weboob urlview googler urlwatch
49
50 # less
51 python3Packages.pygments lesspipe highlight sourceHighlight
52
53 # monitoring
54 cnagios mtop pg_activity nagios-cli mtr
054a2da2 55 iftop htop iotop iperf bonfire
fdf6f74d
IB
56 goaccess
57 # nagnu
58
59 # messaging/forums/news
60 flrn slrn
61 telegram-cli telegram-history-dump telegramircd
62 weechat profanity
63 newsboat irssi
64
65 # nix
66 mylibs.yarn2nixPackage.yarn2nix
67 nixops nix-prefetch-scripts nix-generate-from-cpan
68 nix-zsh-completions bundix nodePackages.bower2nix
803d2d9f 69 nodePackages.node2nix
fdf6f74d
IB
70 # (nixos {}).nixos-generate-config
71 # (nixos {}).nixos-install
72 # (nixos {}).nixos-enter
73 # (nixos {}).manual.manpages
74
75 # note taking
76 note terminal-velocity jrnl
77
78 # office
79 sc-im ranger
80 genius bc
81 ledger
82 tmux
83 rtorrent
84 ldapvi
054a2da2 85 fzf
fdf6f74d
IB
86
87 # password management
88 pass apg pwgen
89
90 # pdf
91 pdftk poppler_utils
92
93 # programming
94 pelican emacs26-nox ctags
e820fa7d 95 wdiff
fdf6f74d
IB
96
97 # security
98 keybase
99
100 # todolist/time management
101 taskwarrior vit timewarrior
102
103 # video/music
104 youtube-dl ncmpc ncmpcpp ffmpeg
105
b8951433
IB
106 # s6 tools (part of skawarePackages)
107 skalibs execline s6 s6-dns s6-linux-utils s6-networking
108 s6-portable-utils
109
fdf6f74d
IB
110 # other tools
111 pgloader s3cmd lftp jq cpulimit libxslt
e886ea19
IB
112
113 # Terraform + AWS
114 terraform_0_12 awscli
115 (ansible.override { python2 = python3; }) python3Packages.boto
116 openvpn
fdf6f74d
IB
117 ];
118in
119{
120 myEnvironments.immae-eu = buildEnv {
121 name = "immae-eu-packages";
122 inherit paths;
123 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
124 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
125 };
126}