]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - libs.nix
Move nixpkgs import to libs
[perso/Immae/Config/Nix.git] / libs.nix
CommitLineData
dc101440
IB
1let nixpkgs_unstable = import (builtins.fetchTarball {
2 # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
3 # versions
4 name = "nixos-unstable-2018-12-08";
5 url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
6 sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
7}) {};
8in
9 with nixpkgs_unstable;
10{
11 inherit nixpkgs_unstable;
12 fetchedGithub = path:
13 let
14 json = lib.importJSON path;
15 in rec {
16 version = json.tag;
17 name = "${json.meta.name}-${version}";
18 src = fetchFromGitHub json.github;
19 };
20
21 fetchedGit = path:
22 let
23 json = lib.importJSON path;
24 in rec {
25 version = json.tag;
26 name = "${json.meta.name}-${version}";
27 src = fetchgit json.git;
28 };
29}