]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - environments/immae-eu.nix
Upgrade etherpad-lite
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
CommitLineData
8c90ed19 1{ pkgs }: with pkgs;
fdf6f74d
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
6a380f40 20 cardano cardano-cli sia monero
fdf6f74d
IB
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
e96787f1 26 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
22ba294f 34 neomutt mairix
fdf6f74d 35 bogofilter fetchmail
dc6d3af9 36 sieve-connect
fdf6f74d
IB
37
38 # git
50c100ba 39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
fdf6f74d
IB
40
41 # graphical tools
42 nextcloud-client firefox
50c100ba 43 dwm dmenu st xorg.xauth tigervnc
fdf6f74d
IB
44
45 # images
054a2da2 46 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
47
48 # internet browsing
e6052491 49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
fdf6f74d
IB
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
054a2da2 56 iftop htop iotop iperf bonfire
5138d96c 57 goaccess tcpdump tshark tcpflow mitmproxy
fdf6f74d
IB
58 # nagnu
59
60 # messaging/forums/news
36c368d0 61 #flrn slrn
fdf6f74d
IB
62 telegram-cli telegram-history-dump telegramircd
63 weechat profanity
64 newsboat irssi
65
66 # nix
b6cc59da 67 yarn2nix-moretea.yarn2nix nix
fdf6f74d 68 nixops nix-prefetch-scripts nix-generate-from-cpan
b23c5027 69 bundix nodePackages.bower2nix
ccda44f3 70 nodePackages.node2nix niv
fdf6f74d
IB
71 # (nixos {}).nixos-generate-config
72 # (nixos {}).nixos-install
73 # (nixos {}).nixos-enter
74 # (nixos {}).manual.manpages
75
76 # note taking
50c100ba 77 note terminal-velocity jrnl doing
fdf6f74d
IB
78
79 # office
80 sc-im ranger
81 genius bc
82 ledger
83 tmux
84 rtorrent
85 ldapvi
054a2da2 86 fzf
099ab5fe 87 buku
50c100ba 88 vimPlugins.vim-plug
360b2704 89 (vim_configurable.override { python = python3; })
50c100ba 90 mailcap
fdf6f74d
IB
91
92 # password management
6d5ce738 93 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
fdf6f74d
IB
94
95 # pdf
96 pdftk poppler_utils
97
98 # programming
99 pelican emacs26-nox ctags
50c100ba 100 wdiff patch gnumake
fdf6f74d
IB
101
102 # security
50c100ba 103 keybase gnupg
fdf6f74d
IB
104
105 # todolist/time management
106 taskwarrior vit timewarrior
107
108 # video/music
109 youtube-dl ncmpc ncmpcpp ffmpeg
110
b8951433
IB
111 # s6 tools (part of skawarePackages)
112 skalibs execline s6 s6-dns s6-linux-utils s6-networking
113 s6-portable-utils
114
5138d96c
IB
115 # system tools
116 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
117 wget patchelf rename tmux (lib.meta.hiPrio nettools)
ca732a83 118 vlock mosh manpages openssl
5138d96c 119
fdf6f74d 120 # other tools
5304a64b 121 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
e886ea19
IB
122
123 # Terraform + AWS
124 terraform_0_12 awscli
125 (ansible.override { python2 = python3; }) python3Packages.boto
126 openvpn
fdf6f74d
IB
127 ];
128in
8c90ed19
IB
129buildEnv {
130 name = "immae-eu-packages";
131 inherit paths;
132 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
133 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
134 passthru = { packages = paths; };
fdf6f74d 135}