]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - environments/immae-eu.nix
Upgrade stgit
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
CommitLineData
8c90ed19 1{ pkgs }: with pkgs;
fdf6f74d
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
f9914beb 7 lzo unzip bzip2 xz
fdf6f74d
IB
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
05a3b252 14 abook khard khal cadaver vdirsyncerStable pal
fdf6f74d
IB
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
6e80545d 20 monero
ca5478c6 21 # failing xmr-stak
fdf6f74d
IB
22 solc
23 iota-cli-app
24
25 # debugging
e96787f1 26 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
22ba294f 34 neomutt mairix
fdf6f74d 35 bogofilter fetchmail
dc6d3af9 36 sieve-connect
fdf6f74d
IB
37
38 # git
a940a796 39 vcsh gitRepo stgit tig ripgrep mr
fdf6f74d
IB
40
41 # graphical tools
42 nextcloud-client firefox
50c100ba 43 dwm dmenu st xorg.xauth tigervnc
fdf6f74d
IB
44
45 # images
054a2da2 46 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
47
48 # internet browsing
5be300c1 49 w3m lynx links elinks browsh woob urlview urlscan googler urlwatch
fdf6f74d
IB
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
054a2da2 56 iftop htop iotop iperf bonfire
12720877 57 goaccess tcpdump tshark tcpflow
ca5478c6 58 mitmproxy
fdf6f74d
IB
59 # nagnu
60
61 # messaging/forums/news
033bd2b4 62 flrn slrn
a3ef18ac 63 signal-cli signaldctl
fdf6f74d
IB
64 telegram-cli telegram-history-dump telegramircd
65 weechat profanity
66 newsboat irssi
67
68 # nix
a0e80453 69 yarn2nix-moretea.yarn2nix nixUnstable
fdf6f74d 70 nixops nix-prefetch-scripts nix-generate-from-cpan
f5cbc6f7 71 bundix nodePackages.bower2nix nix-diff
ccda44f3 72 nodePackages.node2nix niv
fdf6f74d
IB
73 # (nixos {}).nixos-generate-config
74 # (nixos {}).nixos-install
75 # (nixos {}).nixos-enter
76 # (nixos {}).manual.manpages
77
78 # note taking
033bd2b4 79 note terminal-velocity jrnl doing nb
fdf6f74d
IB
80
81 # office
82 sc-im ranger
83 genius bc
84 ledger
85 tmux
86 rtorrent
87 ldapvi
054a2da2 88 fzf
c31ca68c 89 buku
50c100ba 90 vimPlugins.vim-plug
360b2704 91 (vim_configurable.override { python = python3; })
50c100ba 92 mailcap
91b3d06b 93 webapps.surfer
fdf6f74d
IB
94
95 # password management
6d5ce738 96 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
fdf6f74d
IB
97
98 # pdf
99 pdftk poppler_utils
100
101 # programming
102 pelican emacs26-nox ctags
50c100ba 103 wdiff patch gnumake
fdf6f74d
IB
104
105 # security
50c100ba 106 keybase gnupg
fdf6f74d
IB
107
108 # todolist/time management
6e80545d 109 taskwarrior vit timewarrior taskopen
9970dfe6 110 bugwarrior
fdf6f74d
IB
111
112 # video/music
113 youtube-dl ncmpc ncmpcpp ffmpeg
114
b8951433
IB
115 # s6 tools (part of skawarePackages)
116 skalibs execline s6 s6-dns s6-linux-utils s6-networking
117 s6-portable-utils
118
5138d96c
IB
119 # system tools
120 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
121 wget patchelf rename tmux (lib.meta.hiPrio nettools)
840812f2 122 vlock mosh manpages openssl openssl.doc openssl.man
6e80545d 123 sshfs ncdu procps-ng
5138d96c 124
fdf6f74d 125 # other tools
200690c9 126 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli bubblewrap
e886ea19
IB
127
128 # Terraform + AWS
129 terraform_0_12 awscli
f9914beb 130 ansible python3Packages.boto
e886ea19 131 openvpn
840812f2
IB
132
133 zsh-completions
fdf6f74d
IB
134 ];
135in
8c90ed19
IB
136buildEnv {
137 name = "immae-eu-packages";
138 inherit paths;
139 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
140 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
141 passthru = { packages = paths; };
fdf6f74d 142}