]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - environments/immae-eu.nix
WIP upgrade
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
CommitLineData
8c90ed19 1{ pkgs }: with pkgs;
fdf6f74d
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
de4aa7a9
IB
5 vlock' = vlock.overrideAttrs(old: {
6 configureFlags = old.configureFlags ++ [ "--enable-root-password=no" ];
7 });
fdf6f74d
IB
8 paths = [
9 # archives
f9914beb 10 lzo unzip bzip2 xz
fdf6f74d
IB
11 # unrar is unfree
12
13 # backups
14 duply
15
16 # calendar/contacts
05a3b252 17 abook khard khal cadaver vdirsyncerStable pal
fdf6f74d
IB
18
19 # computing
20 boinctui
21
22 # cryptocurrencies
6e80545d 23 monero
de4aa7a9 24 cointop
ca5478c6 25 # failing xmr-stak
fdf6f74d
IB
26 solc
27 iota-cli-app
28
29 # debugging
e96787f1 30 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
31
32 # documentations
33 unicodeDoc
34
35 # e-mails
36 muttprint mutt-ics
e34b3079 37 notmuch-python3 notmuch-vim
22ba294f 38 neomutt mairix
fdf6f74d 39 bogofilter fetchmail
dc6d3af9 40 sieve-connect
fdf6f74d
IB
41
42 # git
d3a43b08 43 vcsh gitRepo stgit tig ripgrep mr delta
fdf6f74d
IB
44
45 # graphical tools
46 nextcloud-client firefox
50c100ba 47 dwm dmenu st xorg.xauth tigervnc
fdf6f74d
IB
48
49 # images
054a2da2 50 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
51
52 # internet browsing
e34b3079 53 w3m lynx links2 elinks browsh python3Packages.woob urlview urlscan googler urlwatch
fdf6f74d
IB
54
55 # less
56 python3Packages.pygments lesspipe highlight sourceHighlight
57
58 # monitoring
59 cnagios mtop pg_activity nagios-cli mtr
054a2da2 60 iftop htop iotop iperf bonfire
e34b3079 61 goaccess tcpdump wireshark-cli tcpflow
ca5478c6 62 mitmproxy
fdf6f74d
IB
63 # nagnu
64
65 # messaging/forums/news
033bd2b4 66 flrn slrn
a3ef18ac 67 signal-cli signaldctl
fdf6f74d
IB
68 telegram-cli telegram-history-dump telegramircd
69 weechat profanity
70 newsboat irssi
71
72 # nix
a0e80453 73 yarn2nix-moretea.yarn2nix nixUnstable
e34b3079 74 nix-prefetch-scripts nix-generate-from-cpan
f5cbc6f7 75 bundix nodePackages.bower2nix nix-diff
ccda44f3 76 nodePackages.node2nix niv
fdf6f74d
IB
77 # (nixos {}).nixos-generate-config
78 # (nixos {}).nixos-install
79 # (nixos {}).nixos-enter
80 # (nixos {}).manual.manpages
81
82 # note taking
033bd2b4 83 note terminal-velocity jrnl doing nb
fdf6f74d
IB
84
85 # office
86 sc-im ranger
87 genius bc
88 ledger
89 tmux
90 rtorrent
91 ldapvi
054a2da2 92 fzf
c31ca68c 93 buku
50c100ba 94 vimPlugins.vim-plug
360b2704 95 (vim_configurable.override { python = python3; })
50c100ba 96 mailcap
91b3d06b 97 webapps.surfer
fdf6f74d
IB
98
99 # password management
6d5ce738 100 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
fdf6f74d
IB
101
102 # pdf
103 pdftk poppler_utils
104
105 # programming
e34b3079 106 emacs-nox ctags
50c100ba 107 wdiff patch gnumake
fdf6f74d
IB
108
109 # security
50c100ba 110 keybase gnupg
fdf6f74d
IB
111
112 # todolist/time management
6e80545d 113 taskwarrior vit timewarrior taskopen
9970dfe6 114 bugwarrior
fdf6f74d
IB
115
116 # video/music
117 youtube-dl ncmpc ncmpcpp ffmpeg
118
b8951433
IB
119 # s6 tools (part of skawarePackages)
120 skalibs execline s6 s6-dns s6-linux-utils s6-networking
121 s6-portable-utils
122
5138d96c 123 # system tools
e34b3079 124 inetutils bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
5138d96c 125 wget patchelf rename tmux (lib.meta.hiPrio nettools)
e34b3079 126 vlock' mosh man-pages openssl openssl.doc openssl.man
d3a43b08 127 sshfs ncdu procps-watch8bit
5138d96c 128
fdf6f74d 129 # other tools
200690c9 130 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli bubblewrap
e886ea19 131
e34b3079
IB
132 # AWS
133 awscli
134 ansible
e886ea19 135 openvpn
840812f2
IB
136
137 zsh-completions
d3a43b08 138
e34b3079 139 python3Packages.hetzner
d3a43b08 140 smartmontools
fdf6f74d
IB
141 ];
142in
8c90ed19
IB
143buildEnv {
144 name = "immae-eu-packages";
145 inherit paths;
146 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
147 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
148 passthru = { packages = paths; };
fdf6f74d 149}