]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - environments/immae-eu.nix
migrate secondary DNS to Raito
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
CommitLineData
8c90ed19 1{ pkgs }: with pkgs;
fdf6f74d
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
de4aa7a9
IB
5 vlock' = vlock.overrideAttrs(old: {
6 configureFlags = old.configureFlags ++ [ "--enable-root-password=no" ];
7 });
59d1335e
IB
8 go-task' = writeScriptBin "go-task" ''
9 #!/usr/bin/env bash
10
11 export TASK_TEMP_DIR=$XDG_STATE_HOME/go-task
12 exec ${go-task}/bin/go-task -t $XDG_CONFIG_HOME/go-task/Taskfile.yaml "$@"
13 '';
14
fdf6f74d
IB
15 paths = [
16 # archives
f9914beb 17 lzo unzip bzip2 xz
fdf6f74d
IB
18 # unrar is unfree
19
20 # backups
21 duply
22
23 # calendar/contacts
05a3b252 24 abook khard khal cadaver vdirsyncerStable pal
fdf6f74d
IB
25
26 # computing
27 boinctui
28
29 # cryptocurrencies
6e80545d 30 monero
de4aa7a9 31 cointop
ca5478c6 32 # failing xmr-stak
fdf6f74d
IB
33 solc
34 iota-cli-app
35
36 # debugging
e96787f1 37 rr valgrind netcat-gnu strace shellcheck
fdf6f74d
IB
38
39 # documentations
40 unicodeDoc
41
42 # e-mails
43 muttprint mutt-ics
e34b3079 44 notmuch-python3 notmuch-vim
22ba294f 45 neomutt mairix
fdf6f74d 46 bogofilter fetchmail
dc6d3af9 47 sieve-connect
fdf6f74d
IB
48
49 # git
d3a43b08 50 vcsh gitRepo stgit tig ripgrep mr delta
fdf6f74d
IB
51
52 # graphical tools
53 nextcloud-client firefox
50c100ba 54 dwm dmenu st xorg.xauth tigervnc
fdf6f74d
IB
55
56 # images
054a2da2 57 feh imagemagick tiv graphicsmagick qrcode
fdf6f74d
IB
58
59 # internet browsing
e34b3079 60 w3m lynx links2 elinks browsh python3Packages.woob urlview urlscan googler urlwatch
fdf6f74d
IB
61
62 # less
63 python3Packages.pygments lesspipe highlight sourceHighlight
64
65 # monitoring
66 cnagios mtop pg_activity nagios-cli mtr
054a2da2 67 iftop htop iotop iperf bonfire
e34b3079 68 goaccess tcpdump wireshark-cli tcpflow
ca5478c6 69 mitmproxy
fdf6f74d
IB
70 # nagnu
71
72 # messaging/forums/news
033bd2b4 73 flrn slrn
a3ef18ac 74 signal-cli signaldctl
fdf6f74d
IB
75 telegram-cli telegram-history-dump telegramircd
76 weechat profanity
77 newsboat irssi
78
79 # nix
a0e80453 80 yarn2nix-moretea.yarn2nix nixUnstable
e34b3079 81 nix-prefetch-scripts nix-generate-from-cpan
f5cbc6f7 82 bundix nodePackages.bower2nix nix-diff
ccda44f3 83 nodePackages.node2nix niv
fdf6f74d
IB
84 # (nixos {}).nixos-generate-config
85 # (nixos {}).nixos-install
86 # (nixos {}).nixos-enter
87 # (nixos {}).manual.manpages
88
89 # note taking
033bd2b4 90 note terminal-velocity jrnl doing nb
fdf6f74d
IB
91
92 # office
93 sc-im ranger
94 genius bc
95 ledger
96 tmux
97 rtorrent
98 ldapvi
054a2da2 99 fzf
c31ca68c 100 buku
50c100ba 101 vimPlugins.vim-plug
360b2704 102 (vim_configurable.override { python = python3; })
50c100ba 103 mailcap
91b3d06b 104 webapps.surfer
fdf6f74d
IB
105
106 # password management
6d5ce738 107 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
fdf6f74d
IB
108
109 # pdf
110 pdftk poppler_utils
111
112 # programming
e34b3079 113 emacs-nox ctags
50c100ba 114 wdiff patch gnumake
fdf6f74d
IB
115
116 # security
50c100ba 117 keybase gnupg
fdf6f74d
IB
118
119 # todolist/time management
6e80545d 120 taskwarrior vit timewarrior taskopen
9970dfe6 121 bugwarrior
fdf6f74d
IB
122
123 # video/music
124 youtube-dl ncmpc ncmpcpp ffmpeg
125
b8951433
IB
126 # s6 tools (part of skawarePackages)
127 skalibs execline s6 s6-dns s6-linux-utils s6-networking
128 s6-portable-utils
129
5138d96c 130 # system tools
e34b3079 131 inetutils bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
5138d96c 132 wget patchelf rename tmux (lib.meta.hiPrio nettools)
e34b3079 133 vlock' mosh man-pages openssl openssl.doc openssl.man
d3a43b08 134 sshfs ncdu procps-watch8bit
5138d96c 135
fdf6f74d 136 # other tools
200690c9 137 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli bubblewrap
e886ea19 138
e34b3079
IB
139 # AWS
140 awscli
141 ansible
e886ea19 142 openvpn
840812f2
IB
143
144 zsh-completions
d3a43b08 145
e34b3079 146 python3Packages.hetzner
d3a43b08 147 smartmontools
59d1335e 148 go-task'
fdf6f74d
IB
149 ];
150in
8c90ed19
IB
151buildEnv {
152 name = "immae-eu-packages";
153 inherit paths;
154 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
155 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
156 passthru = { packages = paths; };
fdf6f74d 157}