diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 18 |
1 files changed, 0 insertions, 18 deletions
diff --git a/shell.nix b/shell.nix deleted file mode 100644 index 2295f8c..0000000 --- a/shell.nix +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | { pkgs ? import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); }, | ||
2 | pkgs-nix ? import <nixpkgs-nix> { overlays = builtins.attrValues (import ./overlays); } | ||
3 | }: | ||
4 | let | ||
5 | patchedNix = pkgs-nix.nixUnstable.overrideAttrs(old: { | ||
6 | patches = old.patches ++ [ | ||
7 | # Fix the ETag bug. PR merged. Remove when updating to >= 20210125 | ||
8 | # https://github.com/NixOS/nixpkgs/pull/109309#issuecomment-768331750 | ||
9 | (pkgs-nix.fetchpatch { | ||
10 | url = "https://patch-diff.githubusercontent.com/raw/NixOS/nix/pull/4470.diff"; | ||
11 | sha256 = "sha256-d4RNOKMxa4NMbFgYcqWRv2ByHt8F/XUWV+6P9qHz7S4="; | ||
12 | }) | ||
13 | ]; | ||
14 | }); | ||
15 | in | ||
16 | pkgs.mkShell { | ||
17 | buildInputs = [ patchedNix pkgs.sops pkgs.morph pkgs.niv pkgs.curl pkgs.shellcheck pkgs.jq pkgs.gnumake pkgs.yq ]; | ||
18 | } | ||