aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /shell.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 2295f8c..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,18 +0,0 @@
1{ pkgs ? import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); },
2 pkgs-nix ? import <nixpkgs-nix> { overlays = builtins.attrValues (import ./overlays); }
3}:
4let
5 patchedNix = pkgs-nix.nixUnstable.overrideAttrs(old: {
6 patches = old.patches ++ [
7 # Fix the ETag bug. PR merged. Remove when updating to >= 20210125
8 # https://github.com/NixOS/nixpkgs/pull/109309#issuecomment-768331750
9 (pkgs-nix.fetchpatch {
10 url = "https://patch-diff.githubusercontent.com/raw/NixOS/nix/pull/4470.diff";
11 sha256 = "sha256-d4RNOKMxa4NMbFgYcqWRv2ByHt8F/XUWV+6P9qHz7S4=";
12 })
13 ];
14 });
15in
16pkgs.mkShell {
17 buildInputs = [ patchedNix pkgs.sops pkgs.morph pkgs.niv pkgs.curl pkgs.shellcheck pkgs.jq pkgs.gnumake pkgs.yq ];
18}