aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index b7589eb..77e9c8d 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -133,8 +133,8 @@ let
133 ''; 133 '';
134 type = submodule { 134 type = submodule {
135 options = { 135 options = {
136 password = mkOption { type = string; description = "Password for the LDAP connection"; }; 136 password = mkOption { type = str; description = "Password for the LDAP connection"; };
137 dn = mkOption { type = string; description = "DN for the LDAP connection"; }; 137 dn = mkOption { type = str; description = "DN for the LDAP connection"; };
138 }; 138 };
139 }; 139 };
140 }; 140 };
@@ -156,13 +156,13 @@ let
156 type = attrsOf (submodule { 156 type = attrsOf (submodule {
157 options = { 157 options = {
158 ip4 = mkOption { 158 ip4 = mkOption {
159 type = string; 159 type = str;
160 description = '' 160 description = ''
161 ip4 address of the host 161 ip4 address of the host
162 ''; 162 '';
163 }; 163 };
164 ip6 = mkOption { 164 ip6 = mkOption {
165 type = listOf string; 165 type = listOf str;
166 default = []; 166 default = [];
167 description = '' 167 description = ''
168 ip6 addresses of the host 168 ip6 addresses of the host