aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-03-25 11:57:48 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-04-03 16:25:07 +0200
commit5400b9b6f65451d41a9106fae6fc00f97d83f4ef (patch)
tree6ed072da7b1f17ac3994ffea052aa0c0822f8446 /modules/private/environment.nix
parent441da8aac378f401625e82caf281fa0e26128310 (diff)
downloadNix-5400b9b6f65451d41a9106fae6fc00f97d83f4ef.tar.gz
Nix-5400b9b6f65451d41a9106fae6fc00f97d83f4ef.tar.zst
Nix-5400b9b6f65451d41a9106fae6fc00f97d83f4ef.zip
Upgrade nixos
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index b7589eb..77e9c8d 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -133,8 +133,8 @@ let
133 ''; 133 '';
134 type = submodule { 134 type = submodule {
135 options = { 135 options = {
136 password = mkOption { type = string; description = "Password for the LDAP connection"; }; 136 password = mkOption { type = str; description = "Password for the LDAP connection"; };
137 dn = mkOption { type = string; description = "DN for the LDAP connection"; }; 137 dn = mkOption { type = str; description = "DN for the LDAP connection"; };
138 }; 138 };
139 }; 139 };
140 }; 140 };
@@ -156,13 +156,13 @@ let
156 type = attrsOf (submodule { 156 type = attrsOf (submodule {
157 options = { 157 options = {
158 ip4 = mkOption { 158 ip4 = mkOption {
159 type = string; 159 type = str;
160 description = '' 160 description = ''
161 ip4 address of the host 161 ip4 address of the host
162 ''; 162 '';
163 }; 163 };
164 ip6 = mkOption { 164 ip6 = mkOption {
165 type = listOf string; 165 type = listOf str;
166 default = []; 166 default = [];
167 description = '' 167 description = ''
168 ip6 addresses of the host 168 ip6 addresses of the host