]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blobdiff - overlays/environments/immae-eu.nix
Add some packages to environment
[perso/Immae/Config/Nix/NUR.git] / overlays / environments / immae-eu.nix
index cc2e5c3f33dd5dbd982b28edeb411c70ef812e61..6287a97b962514279728cbd796194ae76dbcacd8 100644 (file)
@@ -17,7 +17,7 @@ let
     boinctui
 
     # cryptocurrencies
-    cardano sia monero
+    cardano cardano-cli sia monero
     xmr-stak
     solc
     iota-cli-app
@@ -33,6 +33,7 @@ let
     notmuch-python2 notmuch-python3 notmuch-vim
     neomutt mairix notmuch
     bogofilter fetchmail
+    sieve-connect
 
     # git
     vcsh gitRepo gitAndTools.stgit tig ripgrep
@@ -45,7 +46,7 @@ let
     feh imagemagick tiv graphicsmagick qrcode
 
     # internet browsing
-    w3m lynx links elinks browsh weboob urlview googler urlwatch
+    w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
 
     # less
     python3Packages.pygments lesspipe highlight sourceHighlight
@@ -53,11 +54,11 @@ let
     # monitoring
     cnagios mtop pg_activity nagios-cli mtr
     iftop htop iotop iperf bonfire
-    goaccess
+    goaccess tcpdump tshark tcpflow mitmproxy
     # nagnu
 
     # messaging/forums/news
-    flrn slrn
+    #flrn slrn
     telegram-cli telegram-history-dump telegramircd
     weechat profanity
     newsboat irssi
@@ -93,7 +94,7 @@ let
 
     # programming
     pelican emacs26-nox ctags
-    wdiff
+    wdiff patch
 
     # security
     keybase
@@ -108,6 +109,10 @@ let
     skalibs execline s6 s6-dns s6-linux-utils s6-networking
     s6-portable-utils
 
+    # system tools
+    telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
+    wget patchelf rename tmux (lib.meta.hiPrio nettools)
+
     # other tools
     pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
 
@@ -123,5 +128,6 @@ in
     inherit paths;
     pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
     extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
+    passthru = { packages = paths; };
   };
 }