]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame_incremental - pkgs/telethon_sync/default.nix
Initial commit published for NUR
[perso/Immae/Config/Nix/NUR.git] / pkgs / telethon_sync / default.nix
... / ...
CommitLineData
1{ lib, python3Packages }:
2with python3Packages;
3buildPythonPackage rec {
4 pname = "Telethon-sync";
5 version = "1.1.1";
6
7 src = fetchPypi {
8 inherit pname version;
9 sha256 =
10 "01z8fzqn0qs5pxhvzq891r3mwffq1ga3f8xvm7qdn6kvmxjni9fy";
11 };
12
13 propagatedBuildInputs = [
14 rsa pyaes async_generator
15 ];
16 doCheck = false;
17
18 meta = with lib; {
19 homepage = https://github.com/LonamiWebs/Telethon;
20 description = "Full-featured Telegram client library for Python 3";
21 license = licenses.mit;
22 };
23}