]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame - pkgs/telethon_sync/default.nix
Use fetchgit rather than builtins
[perso/Immae/Config/Nix/NUR.git] / pkgs / telethon_sync / default.nix
CommitLineData
9951b235 1{ lib, python3Packages, fetchgit }:
24fd1fe6
IB
2with python3Packages;
3buildPythonPackage rec {
4 pname = "Telethon-sync";
5 version = "1.1.1";
6
9951b235 7 src = fetchgit {
8cc29816 8 url = "https://github.com/LonamiWebs/Telethon";
9951b235 9 branchName = "sync-stale";
8cc29816 10 rev = "6a785a01aa56cfd21c8c5beb9d722c68d664ba5e";
9951b235 11 sha256 = "0g7gnln5kbh1gy6sfb3jg6knmi33n6sgzy2rni2x6af84lza0lgc";
24fd1fe6
IB
12 };
13
14 propagatedBuildInputs = [
15 rsa pyaes async_generator
16 ];
17 doCheck = false;
18
19 meta = with lib; {
20 homepage = https://github.com/LonamiWebs/Telethon;
21 description = "Full-featured Telegram client library for Python 3";
22 license = licenses.mit;
23 };
24}