]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame - environments/immae-eu.nix
Move environments to specific attrs
[perso/Immae/Config/Nix/NUR.git] / environments / immae-eu.nix
CommitLineData
eaa9613a 1{ pkgs }: with pkgs;
24fd1fe6
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
d303c5ae 20 cardano cardano-cli sia monero
24fd1fe6
IB
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
1449c51f 26 rr valgrind netcat-gnu strace shellcheck
24fd1fe6
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
bf5ac71e 36 sieve-connect
24fd1fe6
IB
37
38 # git
4fa343dc 39 vcsh gitRepo gitAndTools.stgit tig ripgrep
24fd1fe6
IB
40
41 # graphical tools
42 nextcloud-client firefox
43 dwm dmenu st
44
45 # images
2cd03c55 46 feh imagemagick tiv graphicsmagick qrcode
24fd1fe6
IB
47
48 # internet browsing
77523524 49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
24fd1fe6
IB
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
2cd03c55 56 iftop htop iotop iperf bonfire
c6963493 57 goaccess tcpdump tshark tcpflow mitmproxy
24fd1fe6
IB
58 # nagnu
59
60 # messaging/forums/news
b57f31fb 61 #flrn slrn
24fd1fe6
IB
62 telegram-cli telegram-history-dump telegramircd
63 weechat profanity
64 newsboat irssi
65
66 # nix
d8a4e41a 67 mylibs.yarn2nixPackage.yarn2nix nix
24fd1fe6
IB
68 nixops nix-prefetch-scripts nix-generate-from-cpan
69 nix-zsh-completions bundix nodePackages.bower2nix
70 nodePackages.node2nix
71 # (nixos {}).nixos-generate-config
72 # (nixos {}).nixos-install
73 # (nixos {}).nixos-enter
74 # (nixos {}).manual.manpages
75
76 # note taking
77 note terminal-velocity jrnl
78
79 # office
80 sc-im ranger
81 genius bc
82 ledger
83 tmux
84 rtorrent
85 ldapvi
2cd03c55 86 fzf
a24ab80a 87 buku
24fd1fe6
IB
88
89 # password management
90 pass apg pwgen
91
92 # pdf
93 pdftk poppler_utils
94
95 # programming
96 pelican emacs26-nox ctags
c6963493 97 wdiff patch
24fd1fe6
IB
98
99 # security
100 keybase
101
102 # todolist/time management
103 taskwarrior vit timewarrior
104
105 # video/music
106 youtube-dl ncmpc ncmpcpp ffmpeg
107
debc5fae
IB
108 # s6 tools (part of skawarePackages)
109 skalibs execline s6 s6-dns s6-linux-utils s6-networking
110 s6-portable-utils
111
c6963493
IB
112 # system tools
113 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
114 wget patchelf rename tmux (lib.meta.hiPrio nettools)
115
24fd1fe6 116 # other tools
4fa343dc 117 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
b3244321
IB
118
119 # Terraform + AWS
120 terraform_0_12 awscli
121 (ansible.override { python2 = python3; }) python3Packages.boto
122 openvpn
24fd1fe6
IB
123 ];
124in
eaa9613a
IB
125buildEnv {
126 name = "immae-eu-packages";
127 inherit paths;
128 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
129 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
130 passthru = { packages = paths; };
24fd1fe6 131}