]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blame - environments/immae-eu.nix
Use fetchgit rather than builtins
[perso/Immae/Config/Nix/NUR.git] / environments / immae-eu.nix
CommitLineData
eaa9613a 1{ pkgs }: with pkgs;
24fd1fe6
IB
2let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
2d39cc3a 20 cardano cardano-cli sia monero
24fd1fe6
IB
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
1449c51f 26 rr valgrind netcat-gnu strace shellcheck
24fd1fe6
IB
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
486611ba 34 neomutt mairix
24fd1fe6 35 bogofilter fetchmail
bf5ac71e 36 sieve-connect
24fd1fe6
IB
37
38 # git
c566184e 39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
24fd1fe6
IB
40
41 # graphical tools
42 nextcloud-client firefox
c566184e 43 dwm dmenu st xorg.xauth tigervnc
24fd1fe6
IB
44
45 # images
2cd03c55 46 feh imagemagick tiv graphicsmagick qrcode
24fd1fe6
IB
47
48 # internet browsing
77523524 49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
24fd1fe6
IB
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
2cd03c55 56 iftop htop iotop iperf bonfire
c6963493 57 goaccess tcpdump tshark tcpflow mitmproxy
24fd1fe6
IB
58 # nagnu
59
60 # messaging/forums/news
b57f31fb 61 #flrn slrn
24fd1fe6
IB
62 telegram-cli telegram-history-dump telegramircd
63 weechat profanity
64 newsboat irssi
65
66 # nix
7cc59286 67 yarn2nix-moretea.yarn2nix nix
24fd1fe6 68 nixops nix-prefetch-scripts nix-generate-from-cpan
341ee3c6 69 bundix nodePackages.bower2nix
a1cb06e4 70 nodePackages.node2nix niv
24fd1fe6
IB
71 # (nixos {}).nixos-generate-config
72 # (nixos {}).nixos-install
73 # (nixos {}).nixos-enter
74 # (nixos {}).manual.manpages
75
76 # note taking
c566184e 77 note terminal-velocity jrnl doing
24fd1fe6
IB
78
79 # office
80 sc-im ranger
81 genius bc
82 ledger
83 tmux
84 rtorrent
85 ldapvi
2cd03c55 86 fzf
a24ab80a 87 buku
c566184e 88 vimPlugins.vim-plug
98a4617c 89 (vim_configurable.override { python = python3; })
c566184e 90 mailcap
24fd1fe6
IB
91
92 # password management
71c71a99 93 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
24fd1fe6
IB
94
95 # pdf
96 pdftk poppler_utils
97
98 # programming
99 pelican emacs26-nox ctags
c566184e 100 wdiff patch gnumake
24fd1fe6
IB
101
102 # security
c566184e 103 keybase gnupg
24fd1fe6
IB
104
105 # todolist/time management
106 taskwarrior vit timewarrior
107
108 # video/music
109 youtube-dl ncmpc ncmpcpp ffmpeg
110
debc5fae
IB
111 # s6 tools (part of skawarePackages)
112 skalibs execline s6 s6-dns s6-linux-utils s6-networking
113 s6-portable-utils
114
c6963493
IB
115 # system tools
116 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
117 wget patchelf rename tmux (lib.meta.hiPrio nettools)
8b7b8ced 118 vlock mosh manpages openssl
c6963493 119
24fd1fe6 120 # other tools
4fa343dc 121 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
b3244321
IB
122
123 # Terraform + AWS
124 terraform_0_12 awscli
125 (ansible.override { python2 = python3; }) python3Packages.boto
126 openvpn
24fd1fe6
IB
127 ];
128in
eaa9613a
IB
129buildEnv {
130 name = "immae-eu-packages";
131 inherit paths;
132 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
133 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
134 passthru = { packages = paths; };
24fd1fe6 135}