]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index dff105363b77923fe215fef58160af7f7793066c..dc89ae33b0895d19b6b7974bb9ef512da3669d15 100644 (file)
@@ -12,12 +12,13 @@ in {
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "www.immae.eu"; } ];
 
-    services.websites.env.production.vhostConfs.immae = {
-      certName    = "eldiron";
-      addToCerts  = true;
-      hosts       = [ "www.immae.eu" "immae.eu" ];
-      root        = varDir;
-      extraConfig = [
+    services.websites.env.production.vhostConfs.immae_production = {
+      certName     = "immae";
+      addToCerts   = true;
+      certMainHost = "www.immae.eu";
+      hosts        = [ "www.immae.eu" "immae.eu" ];
+      root         = varDir;
+      extraConfig  = [
         ''
         Use Stats www.immae.eu
 
@@ -68,8 +69,8 @@ in {
       ];
     };
 
-    services.websites.env.production.vhostConfs.immaeFr = {
-      certName    = "eldiron";
+    services.websites.env.production.vhostConfs.immae_fr = {
+      certName    = "immae";
       addToCerts  = true;
       hosts       = [ "www.immae.fr" "immae.fr" ];
       root        = null;
@@ -78,8 +79,8 @@ in {
         '' ];
     };
 
-    services.websites.env.production.vhostConfs.bouya = {
-      certName    = "eldiron";
+    services.websites.env.production.vhostConfs.immae_bouya = {
+      certName    = "immae";
       addToCerts  = true;
       hosts       = [ "bouya.org" "www.bouya.org" ];
       root        = null;