1 { lib, pkgs, config, ... }:
3 cfg = config.myServices.websites.immae.production;
4 varDir = "/var/lib/buildbot/outputs/immaeEu";
5 coursDir = "/var/lib/buildbot/outputs/cours";
6 rechercheDir = "/var/lib/buildbot/outputs/recherche";
7 recettesDir = "/var/lib/buildbot/outputs/recettes";
8 env = config.myEnv.websites.immae;
10 options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
12 config = lib.mkIf cfg.enable {
13 services.webstats.sites = [ { name = "www.immae.eu"; } ];
15 services.websites.env.production.vhostConfs.immae_production = {
18 certMainHost = "www.immae.eu";
19 hosts = [ "www.immae.eu" "immae.eu" ];
23 Use Stats www.immae.eu
25 <LocationMatch /.well-known/(webfinger|host-meta)>
26 Header always set Referrer-Policy "strict-origin-when-cross-origin"
27 Header always set Strict-Transport-Security "max-age=31536000"
28 RequestHeader set X-Forwarded-Proto "https"
30 RewriteRule ^(.*)$ https://mastodon.immae.eu%{REQUEST_URI} [QSA,L]
34 RewriteCond "%{REQUEST_URI}" "!^/.well-known/(webfinger|host-meta)"
35 RewriteCond "%{HTTP_HOST}" "!^www\.immae\.eu$" [NC]
36 RewriteRule ^(.+)$ https://www.immae.eu$1 [R=302,L]
39 DirectoryIndex index.htm index.html
40 Options Indexes FollowSymLinks MultiViews Includes
45 Alias /cours ${coursDir}
46 <Directory ${coursDir}>
47 DirectoryIndex index.htm index.html
48 Options Indexes FollowSymLinks MultiViews Includes
53 Alias /recherche ${rechercheDir}
54 <Directory ${rechercheDir}>
55 DirectoryIndex index.htm index.html
56 Options Indexes FollowSymLinks MultiViews Includes
61 Alias /recettes ${recettesDir}
62 <Directory ${recettesDir}>
63 DirectoryIndex index.htm index.html
64 Options Indexes FollowSymLinks MultiViews Includes
72 services.websites.env.production.vhostConfs.immae_fr = {
75 hosts = [ "www.immae.fr" "immae.fr" ];
78 RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.immae.eu/chapeaux/
82 services.websites.env.production.vhostConfs.immae_bouya = {
85 hosts = [ "bouya.org" "www.bouya.org" ];
88 RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.normalesup.org/~bouya/