]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add history page
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index dc89ae33b0895d19b6b7974bb9ef512da3669d15..ae4abe0a1157244ca60e6aa0692ce88749f7e0d6 100644 (file)
@@ -5,6 +5,7 @@ let
   coursDir = "/var/lib/buildbot/outputs/cours";
   rechercheDir = "/var/lib/buildbot/outputs/recherche";
   recettesDir = "/var/lib/buildbot/outputs/recettes";
+  historyDir = pkgs.callPackage ./history {};
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -65,6 +66,13 @@ in {
           AllowOverride All
           Require all granted
         </Directory>
+
+        Alias /history ${historyDir}
+        <Directory ${historyDir}>
+          DirectoryIndex index.html
+          AllowOverride None
+          Require all granted
+        </Directory>
         ''
       ];
     };