]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - libs.nix
Move nixpkgs import to libs
[perso/Immae/Config/Nix.git] / libs.nix
diff --git a/libs.nix b/libs.nix
new file mode 100644 (file)
index 0000000..da13a03
--- /dev/null
+++ b/libs.nix
@@ -0,0 +1,29 @@
+let nixpkgs_unstable = import (builtins.fetchTarball {
+  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
+  # versions
+  name = "nixos-unstable-2018-12-08";
+  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
+  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
+}) {};
+in
+  with nixpkgs_unstable;
+{
+  inherit nixpkgs_unstable;
+  fetchedGithub = path:
+    let
+      json = lib.importJSON path;
+    in rec {
+      version = json.tag;
+      name = "${json.meta.name}-${version}";
+      src = fetchFromGitHub json.github;
+    };
+
+  fetchedGit = path:
+    let
+      json = lib.importJSON path;
+    in rec {
+      version = json.tag;
+      name = "${json.meta.name}-${version}";
+      src = fetchgit json.git;
+    };
+}