]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - systems/monitoring-1/monitoring/master.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / monitoring-1 / monitoring / master.nix
1 { config, ... }:
2 {
3 myServices.monitoring.objects = {
4 contact = {
5 immae = {
6 alias = "Immae";
7 email = config.myEnv.monitoring.immae_contact;
8 use = "generic-contact";
9 contactgroups = "admins";
10 host_notification_commands = "notify-host-by-email,notify-host-by-apprise!$USER210$";
11 service_notification_commands = "notify-service-by-email,notify-service-by-apprise!$USER210$";
12 };
13 };
14 command = {
15 check_passive = "$USER1$/check_dummy 3 \"Service result are stale\"";
16 };
17 templates = {
18 service = {
19 external-passive-service = {
20 active_checks_enabled = "0";
21 check_freshness = "1";
22 check_period = "24x7";
23 contact_groups = "admins";
24 event_handler_enabled = "1";
25 flap_detection_enabled = "1";
26 is_volatile = "0";
27 max_check_attempts = "3";
28 notification_interval = "60";
29 notification_options = "w,u,c,r,f,s";
30 notification_period = "24x7";
31 notifications_enabled = "1";
32 passive_checks_enabled = "1";
33 process_perf_data = "1";
34 retain_nonstatus_information = "1";
35 retain_status_information = "1";
36 retry_interval = "2";
37 check_command = "check_passive";
38 _webstatus_namespace = "immae";
39 };
40 };
41 };
42 };
43 }