]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - systems/eldiron/websites/vpn/default.nix
Add config for CI
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / vpn / default.nix
1 { lib, pkgs, config, ... }:
2 let
3 cfg = config.myServices.vpn;
4 in {
5 config = lib.mkIf cfg.enable {
6 security.acme.certs.eldiron.extraDomainNames = [ "vpn.immae.eu" ];
7 services.websites.env.tools.vhostConfs.vpn = {
8 certName = "eldiron";
9 hosts = [ "vpn.immae.eu" ];
10 root = ./www;
11 };
12 };
13 }