]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/webapps/etherpad-lite/modules/ep_subscript_and_superscript/node-packages.nix
Fix some etherpad-lite modules and packaging
[perso/Immae/Config/Nix.git] / pkgs / webapps / etherpad-lite / modules / ep_subscript_and_superscript / node-packages.nix
1 # This file has been generated by node2nix 1.8.0. Do not edit!
2
3 {nodeEnv, fetchurl, fetchgit, globalBuildInputs ? []}:
4
5 let
6 sources = {};
7 in
8 {
9 ep_subscript_and_superscript = nodeEnv.buildNodePackage {
10 name = "ep_subscript_and_superscript";
11 packageName = "ep_subscript_and_superscript";
12 version = "0.0.3";
13 src = fetchurl {
14 url = "https://registry.npmjs.org/ep_subscript_and_superscript/-/ep_subscript_and_superscript-0.0.3.tgz";
15 sha1 = "47f74a242fe8be5911391943f718eab81c390620";
16 };
17 preRebuild = ''
18 patch -p1 < ${./font.patch}
19 '';
20 buildInputs = globalBuildInputs;
21 meta = {
22 description = "Add support for Subscript and Superscript";
23 };
24 production = true;
25 bypassCache = true;
26 reconstructLock = true;
27 };
28 }