]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/dovecot/plugins/fts_xapian/default.nix
Configure mail (dovecot, postfix, spam checks)
[perso/Immae/Config/Nix.git] / pkgs / dovecot / plugins / fts_xapian / default.nix
1 { stdenv, autoconf, automake, pkg-config, dovecot, libtool, xapian, icu, mylibs }:
2
3 stdenv.mkDerivation (mylibs.fetchedGithub ./fts-xapian.json // rec {
4 buildInputs = [ dovecot autoconf automake libtool pkg-config xapian icu ];
5 preConfigure = ''
6 export PANDOC=false
7 autoreconf -vi
8 '';
9 configureFlags = [
10 "--with-dovecot=${dovecot}/lib/dovecot"
11 "--without-dovecot-install-dirs"
12 "--with-moduledir=$(out)/lib/dovecot"
13 ];
14 })