]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/dovecot/plugins/deleted_to_trash/default.nix
Configure mail (dovecot, postfix, spam checks)
[perso/Immae/Config/Nix.git] / pkgs / dovecot / plugins / deleted_to_trash / default.nix
1 { stdenv, fetchurl, dovecot, mylibs, fetchpatch }:
2
3 stdenv.mkDerivation (mylibs.fetchedGithub ./dovecot-deleted_to_trash.json // rec {
4 buildInputs = [ dovecot ];
5 patches = [
6 (fetchpatch {
7 name = "fix-dovecot-2.3.diff";
8 url = "https://github.com/lexbrugman/dovecot_deleted_to_trash/commit/c52a3799a96104a603ade33404ef6aa1db647b2f.diff";
9 sha256 = "0pld3rdcjp9df2qxbp807k6v4f48lyk0xy5q508ypa57d559y6dq";
10 })
11 ./fix_mbox.patch
12 ];
13 preConfigure = ''
14 substituteInPlace Makefile --replace \
15 "/usr/include/dovecot" \
16 "${dovecot}/include/dovecot"
17 substituteInPlace Makefile --replace \
18 "/usr/lib/dovecot/modules" \
19 "$out/lib/dovecot"
20 '';
21 })