]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
Upgrade stgit
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
11 commento = callPackage ./commento {};
12 cryptpad = callPackage ./cryptpad {};
13 duply = callPackage ./duply {};
14 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
15 genius = callPackage ./genius {};
16 mtop = callPackage ./mtop {};
17 muttprint = callPackage ./muttprint {};
18 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
19 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
20 nagnu = callPackage ./nagnu { inherit mylibs; };
21 nb = callPackage ./nb {};
22 note = callPackage ./note {};
23 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
24 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
25 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
26 openarc = (mylibs.flakeCompat ../flakes/openarc).default;
27 opendmarc = (mylibs.flakeCompat ../flakes/opendmarc).default;
28 pg_activity = callPackage ./pg_activity { inherit mylibs; };
29 pgloader = callPackage ./pgloader {};
30 predixy = callPackage ./predixy { inherit mylibs; };
31 rrsync_sudo = callPackage ./rrsync_sudo {};
32 signald = callPackage ./signald {};
33 signaldctl = callPackage ./signaldctl {};
34 stgit = callPackage ./stgit {};
35 telegram-cli = callPackage ./telegram-cli { inherit mylibs; };
36 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
37 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
38 terminal-velocity = callPackage ./terminal-velocity {};
39 tiv = callPackage ./tiv {};
40 twins = callPackage ./twins {};
41 umami = callPackage ./umami {};
42 unicodeDoc = callPackage ./unicode {};
43
44 cardano = callPackage ./crypto/cardano { inherit mylibs; };
45 cardano-cli = callPackage ./crypto/cardano-cli {};
46 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
47 sia = callPackage ./crypto/sia {};
48
49 pure-ftpd = callPackage ./pure-ftpd {};
50 mpd = (callPackage ./mpd_0_21 {}).mpd;
51 mpd-small = (callPackage ./mpd_0_21 {}).mpd-small;
52
53 bitlbee-mastodon = callPackage ./bitlbee-mastodon {};
54
55 composerEnv = callPackage ./composer-env {};
56 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
57
58 monitoring-plugins = callPackage ./monitoring-plugins {};
59 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
60 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
61 gearmand = callPackage ./gearmand {};
62 status_engine = {
63 module = callPackage ./status_engine/module.nix { inherit mylibs; };
64 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
65 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
66 };
67
68 python3PackagesPlus = callPackage ./python-packages {
69 python = python3;
70 inherit mylibs;
71 };
72 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
73 inherit mylibs;
74 };
75 dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
76 inherit mylibs;
77 };
78
79 fiche = callPackage ./fiche { inherit mylibs; };
80 woob = python3Packages.callPackage ./woob {};
81 zrepl = callPackage ./zrepl {};
82 }