]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - overlays/vdirsyncer/default.nix
Fix acme certificate generation
[perso/Immae/Config/Nix.git] / overlays / vdirsyncer / default.nix
1 self: super: {
2 vdirsyncer = super.vdirsyncer.overridePythonAttrs(old: {
3 # https://github.com/NixOS/nixpkgs/pull/85809
4 postPatch = old.postPatch + ''
5 sed -i "s/invalid value for \"--verbosity\"/invalid value for \\\'--verbosity\\\'/" tests/system/cli/test_sync.py
6 '';
7 });
8 khal = super.khal.overridePythonAttrs(old: {
9 postPatch = ''
10 sed -i "s/Invalid value for \"ics\"/Invalid value for \\\'ics\\\'/" tests/cli_test.py
11 sed -i "s/Invalid value for \"\[ICS\]\"/Invalid value for \\\'[ICS]\\\'/" tests/cli_test.py
12 '';
13 });
14 }