]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - overlays/python-packages/apprise/default.nix
Move spip and chloe website to pkgs
[perso/Immae/Config/Nix.git] / overlays / python-packages / apprise / default.nix
1 self: super: {
2 python3 = super.python3.override {
3 packageOverrides = python-self: python-super: {
4 apprise = python-self.buildPythonPackage rec {
5 pname = "apprise";
6 version = "0.7.4";
7 src = (self.mylibs.fetchedGithub ./apprise.json).src;
8 propagatedBuildInputs = with python-self; [ decorator
9 requests requests_oauthlib oauthlib urllib3 six click
10 markdown pyyaml sleekxmpp
11 ];
12 doChecks = false;
13 };
14 };
15 };
16 }