]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - overlays/nixops/default.nix
Migrate caldance configuration to nixos
[perso/Immae/Config/Nix.git] / overlays / nixops / default.nix
1 self: super: {
2 nixops = super.nixops.overrideAttrs (old: {
3 patches = [
4 ./fix_glibc.patch
5 (self.fetchpatch {
6 name = "hetzner_cloud.patch";
7 url = "https://github.com/goodraven/nixops/commit/272e50d0b0262e49cdcaad42cdab57aad183d1c2.patch";
8 sha256 = "12wcrb0155ald52m7fbr2m5rrxdnwdwripq91ckscgsk42mdc517";
9 })
10 ];
11 preConfigure = (old.preConfigure or "") + ''
12 # https://github.com/NixOS/nixops/issues/1216
13 sed -i -e "/Register the paths in the Nix database./s/#.*$/export USER=root/" nix/libvirtd-image.nix
14
15 sed -i -e '/^import sys$/s/$/; sys.tracebacklimit = 0/' scripts/nixops
16 sed -i -e "/'keyFile'/s/'path'/'string'/" nixops/backends/__init__.py
17 '';
18 });
19 }