]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/ludivine/ludivinecassal.nix
Remove useless relative symlinks
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ludivine / ludivinecassal.nix
1 { pkgs, lib, writeText, fetchedGitPrivate, stdenv, composerEnv, fetchurl, fetchgit, ruby, sass, imagemagick }:
2 let
3 ludivinecassal = { config }: rec {
4 environment = config.environment;
5 varDir = "/var/lib/ludivinecassal_${environment}";
6 configRoot =
7 writeText "parameters.yml" ''
8 # This file is auto-generated during the composer install
9 parameters:
10 database_host: ${config.mysql.host}
11 database_port: ${config.mysql.port}
12 database_name: ${config.mysql.name}
13 database_user: ${config.mysql.user}
14 database_password: ${config.mysql.password}
15 database_server_version: ${pkgs.mariadb.mysqlVersion}
16 mailer_transport: smtp
17 mailer_host: 127.0.0.1
18 mailer_user: null
19 mailer_password: null
20 secret: ${config.secret}
21 ldap_host: ldap.immae.eu
22 ldap_port: 636
23 ldap_version: 3
24 ldap_ssl: true
25 ldap_tls: false
26 ldap_user_bind: 'uid={username},ou=users,dc=immae,dc=eu'
27 ldap_base_dn: 'dc=immae,dc=eu'
28 ldap_search_dn: '${config.ldap.dn}'
29 ldap_search_password: '${config.ldap.password}'
30 ldap_search_filter: '${config.ldap.search}'
31 leapt_im:
32 binary_path: ${imagemagick}/bin
33 assetic:
34 sass: ${sass}/bin/sass
35 ruby: ${ruby}/bin/ruby
36 '';
37 phpFpm = rec {
38 socket = "/var/run/phpfpm/ludivinecassal-${environment}.sock";
39 pool = ''
40 listen = ${socket}
41 user = ${apache.user}
42 group = ${apache.group}
43 listen.owner = ${apache.user}
44 listen.group = ${apache.group}
45 php_admin_value[upload_max_filesize] = 20M
46 php_admin_value[post_max_size] = 20M
47 ;php_admin_flag[log_errors] = on
48 php_admin_value[open_basedir] = "${configRoot}:${webappDir}:${varDir}:/tmp"
49 php_admin_value[session.save_path] = "${varDir}/phpSessions"
50 ${if environment == "dev" then ''
51 pm = ondemand
52 pm.max_children = 5
53 pm.process_idle_timeout = 60
54 env[SYMFONY_DEBUG_MODE] = "yes"
55 '' else ''
56 pm = dynamic
57 pm.max_children = 20
58 pm.start_servers = 2
59 pm.min_spare_servers = 1
60 pm.max_spare_servers = 3
61 ''}'';
62 };
63 apache = rec {
64 user = "wwwrun";
65 group = "wwwrun";
66 modules = [ "proxy_fcgi" ];
67 webappName = "ludivine_${environment}";
68 root = "/run/current-system/webapps/${webappName}";
69 vhostConf = ''
70 <FilesMatch "\.php$">
71 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
72 </FilesMatch>
73
74 ${if environment == "dev" then ''
75 <Location />
76 Use LDAPConnect
77 Require ldap-group cn=ludivine.immae.eu,cn=httpd,ou=services,dc=immae,dc=eu
78 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://ludivinecassal.com\"></html>"
79 </Location>
80
81 <Directory ${root}>
82 Options Indexes FollowSymLinks MultiViews Includes
83 AllowOverride None
84 Require all granted
85
86 DirectoryIndex app_dev.php
87
88 <IfModule mod_negotiation.c>
89 Options -MultiViews
90 </IfModule>
91
92 <IfModule mod_rewrite.c>
93 RewriteEngine On
94
95 RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
96 RewriteRule ^(.*) - [E=BASE:%1]
97
98 # Maintenance script
99 RewriteCond %{DOCUMENT_ROOT}/maintenance.php -f
100 RewriteCond %{SCRIPT_FILENAME} !maintenance.php
101 RewriteRule ^.*$ %{ENV:BASE}/maintenance.php [R=503,L]
102 ErrorDocument 503 /maintenance.php
103
104 # Sets the HTTP_AUTHORIZATION header removed by Apache
105 RewriteCond %{HTTP:Authorization} .
106 RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
107
108 RewriteCond %{ENV:REDIRECT_STATUS} ^$
109 RewriteRule ^app_dev\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
110
111 # If the requested filename exists, simply serve it.
112 # We only want to let Apache serve files and not directories.
113 RewriteCond %{REQUEST_FILENAME} -f
114 RewriteRule ^ - [L]
115
116 # Rewrite all other queries to the front controller.
117 RewriteRule ^ %{ENV:BASE}/app_dev.php [L]
118 </IfModule>
119
120 </Directory>
121 '' else ''
122 Use Stats ludivinecassal.com
123
124 <Directory ${root}>
125 Options Indexes FollowSymLinks MultiViews Includes
126 AllowOverride All
127 Require all granted
128 </Directory>
129 ''}
130 '';
131 };
132 activationScript = {
133 deps = [ "wrappers" ];
134 text = ''
135 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir}
136 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir}/tmp
137 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
138 if [ ! -f "${varDir}/currentWebappDir" -o \
139 "${webappDir}" != "$(cat ${varDir}/currentWebappDir 2>/dev/null)" ]; then
140 pushd ${webappDir} > /dev/null
141 $wrapperDir/sudo -u wwwrun ./bin/console --env=${environment} cache:clear --no-warmup
142 popd > /dev/null
143 echo -n "${webappDir}" > ${varDir}/currentWebappDir
144 fi
145 '';
146 };
147 webappDir = composerEnv.buildPackage (
148 import ./php-packages.nix { inherit composerEnv fetchurl fetchgit; } //
149 fetchedGitPrivate ./ludivinecassal.json //
150 rec {
151 noDev = (environment == "prod");
152 preInstall = ''
153 export SYMFONY_ENV="${environment}"
154 ln -sf ${configRoot} app/config/parameters.yml
155 sed -i -e "/Incenteev..ParameterHandler..ScriptHandler::buildParameters/d" composer.json
156 '';
157 # /!\ miniatures and data need to be in the same physical dir due to a
158 # bug in leapt.im (searches for data/../miniatures)
159 postInstall = ''
160 rm -rf var/{logs,cache,data,miniatures,tmp}
161 ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
162 '';
163 buildInputs = [ sass ];
164 });
165 webRoot = "${webappDir}/web";
166 };
167 in
168 ludivinecassal