]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/chloe/default.nix
Move integration websites to use stable web directory
[perso/Immae/Config/Nix.git] / nixops / modules / websites / chloe / default.nix
1 { lib, pkgs, config, myconfig, mylibs, ... }:
2 let
3 chloe = pkgs.callPackage ./chloe.nix { inherit (mylibs) fetchedGitPrivate; };
4 chloe_dev = chloe {
5 config = myconfig.env.websites.chloe.integration;
6 };
7 chloe_prod = chloe {
8 config = myconfig.env.websites.chloe.production;
9 };
10
11 cfg = config.services.myWebsites.Chloe;
12 in {
13 options.services.myWebsites.Chloe = {
14 production = {
15 enable = lib.mkEnableOption "enable Chloe's website in production";
16 };
17 integration = {
18 enable = lib.mkEnableOption "enable Chloe's website in integration";
19 };
20 };
21
22 imports = [
23 ../commons/stats.nix
24 ];
25
26 config = lib.mkMerge [
27 (lib.mkIf cfg.production.enable {
28 services.myWebsites.commons.stats.enable = true;
29 services.myWebsites.commons.stats.sites = [
30 {
31 name = "osteopathe-cc.fr";
32 conf = ./goaccess.conf;
33 }
34 ];
35
36 security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
37 domain = "osteopathe-cc.fr";
38 extraDomains = {
39 "www.osteopathe-cc.fr" = null;
40 };
41 };
42
43 services.myPhpfpm.poolConfigs.chloe_prod = chloe_prod.phpFpm.pool;
44 services.myPhpfpm.poolPhpConfigs.chloe_prod = ''
45 extension=${pkgs.php}/lib/php/extensions/mysqli.so
46 '';
47 system.activationScripts.chloe_prod = chloe_prod.activationScript;
48 system.extraSystemBuilderCmds = ''
49 mkdir -p $out/webapps
50 ln -s ${chloe_prod.webRoot} $out/webapps/${chloe_prod.apache.webappName}
51 '';
52 services.myWebsites.production.modules = chloe_prod.apache.modules;
53 services.myWebsites.production.vhostConfs.chloe = {
54 certName = "chloe";
55 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
56 root = chloe_prod.webRoot;
57 extraConfig = [ chloe_prod.apache.vhostConf ];
58 };
59 })
60 (lib.mkIf cfg.integration.enable {
61 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
62 services.myPhpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool;
63 services.myPhpfpm.poolPhpConfigs.chloe_dev = ''
64 extension=${pkgs.php}/lib/php/extensions/mysqli.so
65 '';
66 system.activationScripts.chloe_dev = chloe_dev.activationScript;
67 system.extraSystemBuilderCmds = ''
68 mkdir -p $out/webapps
69 ln -s ${chloe_dev.webRoot} $out/webapps/${chloe_dev.apache.webappName}
70 '';
71 services.myWebsites.integration.modules = chloe_dev.apache.modules;
72 services.myWebsites.integration.vhostConfs.chloe = {
73 certName = "eldiron";
74 hosts = ["chloe.immae.eu" ];
75 root = chloe_dev.apache.root;
76 extraConfig = [ chloe_dev.apache.vhostConf ];
77 };
78 })
79 ];
80 }