]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/mail.nix
Move secrets module outside of nixops
[perso/Immae/Config/Nix.git] / nixops / modules / mail.nix
1 { lib, pkgs, config, myconfig, mylibs, ... }:
2 {
3 config.users.users.nullmailer.uid = config.ids.uids.nullmailer;
4 config.users.groups.nullmailer.gid = config.ids.gids.nullmailer;
5
6 config.services.nullmailer = {
7 enable = true;
8 config = {
9 me = myconfig.env.mail.host;
10 remotes = "${myconfig.env.mail.relay} smtp";
11 };
12 };
13 }