]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/eldiron.nix
Use acme directory config rather than hardcoding the value
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
1 { privateFiles ? ./. }:
2 {
3 network = {
4 description = "Immae's network";
5 enableRollback = true;
6 };
7
8 eldiron = { config, pkgs, mylibs, myconfig, ... }:
9 {
10 nixpkgs.overlays = builtins.attrValues (import ../overlays);
11 _module.args = {
12 pkgsNext = import <nixpkgsNext> {};
13 pkgsPrevious = import <nixpkgsPrevious> {};
14 mylibs = import ../libs.nix { inherit pkgs; };
15 myconfig = {
16 inherit privateFiles;
17 env = import "${privateFiles}/environment.nix";
18 };
19 };
20
21 boot.kernelPackages = pkgs.linuxPackages_latest;
22
23 networking = {
24 firewall.enable = true;
25 # 176.9.151.89 declared in nixops -> infra / tools
26 interfaces."eth0".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
27 (n: ips: { address = ips.ip4; prefixLength = 32; })
28 (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") myconfig.env.servers.eldiron.ips);
29 interfaces."eth0".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
30 (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
31 myconfig.env.servers.eldiron.ips);
32 };
33
34 imports = [
35 ./modules/ssh
36 ./modules/certificates.nix
37 ./modules/gitolite
38 ./modules/mpd.nix
39 ./modules/websites
40 ./modules/mail.nix
41 ./modules/ftp.nix
42 ./modules/pub
43 ./modules/task
44 ./modules/irc.nix
45 ./modules/buildbot
46 ./modules/dns.nix
47 ] ++ (builtins.attrValues (import ../modules));
48 myServices.databases.enable = true;
49 services.myGitolite.enable = true;
50 services.pure-ftpd.enable = true;
51 services.irc.enable = true;
52 services.pub.enable = true;
53 services.myTasks.enable = true;
54 services.buildbot.enable = true;
55
56 services.journald.extraConfig = ''
57 MaxLevelStore="warning"
58 MaxRetentionSec="1year"
59 '';
60
61 deployment = {
62 targetEnv = "hetzner";
63 hetzner = {
64 robotUser = myconfig.env.hetzner.user;
65 robotPass = myconfig.env.hetzner.pass;
66 mainIPv4 = myconfig.env.servers.eldiron.ips.main.ip4;
67 partitions = ''
68 clearpart --all --initlabel --drives=sda,sdb
69
70 part swap1 --recommended --label=swap1 --fstype=swap --ondisk=sda
71 part swap2 --recommended --label=swap2 --fstype=swap --ondisk=sdb
72
73 part raid.1 --grow --ondisk=sda
74 part raid.2 --grow --ondisk=sdb
75
76 raid / --level=1 --device=md0 --fstype=ext4 --label=root raid.1 raid.2
77 '';
78 };
79 };
80
81 users.users.root.packages = [
82 pkgs.telnet
83 pkgs.htop
84 pkgs.iftop
85 ];
86
87 environment.systemPackages = [
88 pkgs.vim
89 ];
90
91 services.cron = {
92 enable = true;
93 systemCronJobs = [
94 ''
95 # The star after /var/lib/* avoids deleting all folders in case of problem
96 0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu: > /dev/null
97 ''
98 ];
99 };
100
101 # This value determines the NixOS release with which your system is
102 # to be compatible, in order to avoid breaking some software such as
103 # database servers. You should change this only after NixOS release
104 # notes say you should.
105 system.stateVersion = "18.09"; # Did you read the comment?
106 };
107 }