]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/tools/vpn/default.nix
Add Tinc VPN
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / vpn / default.nix
1 { lib, pkgs, config, ... }:
2 let
3 cfg = config.myServices.vpn;
4 in {
5 config = lib.mkIf cfg.enable {
6 services.websites.env.tools.vhostConfs.vpn = {
7 certName = "eldiron";
8 addToCerts = true;
9 hosts = [ "vpn.immae.eu" ];
10 root = "/run/current-system/webapps/_vpn";
11 };
12
13 myServices.websites.webappDirs._vpn = ./www;
14 };
15 }