]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/ludivinecassal/production.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / ludivinecassal / production.nix
1 { lib, pkgs, config, ... }:
2 let
3 secrets = config.myEnv.websites.ludivinecassal.production;
4 app = pkgs.webapps.ludivinecassal.override { environment = secrets.environment; };
5 pcfg = config.services.phpApplication;
6 cfg = config.myServices.websites.ludivinecassal.production;
7 in {
8 options.myServices.websites.ludivinecassal.production.enable = lib.mkEnableOption "enable Ludivine's website in production";
9
10 config = lib.mkIf cfg.enable {
11 services.duplyBackup.profiles.ludivinecassal_prod.rootDir = app.varDir;
12 services.webstats.sites = [ { name = "ludivinecassal.com"; } ];
13 services.phpApplication.apps.ludivinecassal_prod = {
14 websiteEnv = "production";
15 httpdUser = config.services.httpd.Prod.user;
16 httpdGroup = config.services.httpd.Prod.group;
17 inherit (app) webRoot varDir;
18 varDirPaths = {
19 "tmp" = "0700";
20 };
21 inherit app;
22 serviceDeps = [ "mysql.service" ];
23 preStartActions = [
24 "./bin/console --env=${app.environment} cache:clear --no-warmup"
25 ];
26 phpOpenbasedir = [ "/tmp" ];
27 phpPool = {
28 "php_admin_value[upload_max_filesize]" = "20M";
29 "php_admin_value[post_max_size]" = "20M";
30 #"php_admin_flag[log_errors]" = "on";
31 "pm" = "dynamic";
32 "pm.max_children" = "20";
33 "pm.start_servers" = "2";
34 "pm.min_spare_servers" = "1";
35 "pm.max_spare_servers" = "3";
36 };
37 phpWatchFiles = [
38 config.secrets.fullPaths."webapps/${app.environment}-ludivinecassal"
39 ];
40 };
41
42 secrets.keys = [
43 {
44 dest = "webapps/${app.environment}-ludivinecassal";
45 user = config.services.httpd.Prod.user;
46 group = config.services.httpd.Prod.group;
47 permissions = "0400";
48 text = ''
49 # This file is auto-generated during the composer install
50 parameters:
51 database_host: ${secrets.mysql.host}
52 database_port: ${secrets.mysql.port}
53 database_name: ${secrets.mysql.database}
54 database_user: ${secrets.mysql.user}
55 database_password: ${secrets.mysql.password}
56 database_server_version: ${pkgs.mariadb.mysqlVersion}
57 mailer_transport: smtp
58 mailer_host: 127.0.0.1
59 mailer_user: null
60 mailer_password: null
61 secret: ${secrets.secret}
62 ldap_host: ldap.immae.eu
63 ldap_port: 636
64 ldap_version: 3
65 ldap_ssl: true
66 ldap_tls: false
67 ldap_user_bind: 'uid={username},ou=users,dc=immae,dc=eu'
68 ldap_base_dn: 'dc=immae,dc=eu'
69 ldap_search_dn: '${secrets.ldap.dn}'
70 ldap_search_password: '${secrets.ldap.password}'
71 ldap_search_filter: '${secrets.ldap.filter}'
72 leapt_im:
73 binary_path: ${pkgs.imagemagick}/bin
74 assetic:
75 sass: ${pkgs.sass}/bin/sass
76 ruby: ${pkgs.ruby}/bin/ruby
77 '';
78 }
79 ];
80
81 services.websites.env.production.vhostConfs.ludivinecassal_prod = {
82 certName = "ludivinecassal";
83 certMainHost = "ludivinecassal.com";
84 hosts = ["ludivinecassal.com" "www.ludivinecassal.com" ];
85 root = pcfg.webappDirs.ludivinecassal_prod;
86 extraConfig = [
87 ''
88 RewriteEngine on
89 RewriteCond "%{HTTP_HOST}" "!^ludivinecassal\.com$" [NC]
90 RewriteRule ^(.+)$ https://ludivinecassal.com$1 [R=302,L]
91
92 <FilesMatch "\.php$">
93 SetHandler "proxy:unix:${pcfg.phpListenPaths.ludivinecassal_prod}|fcgi://localhost"
94 </FilesMatch>
95
96 Use Stats ludivinecassal.com
97
98 <Directory ${pcfg.webappDirs.ludivinecassal_prod}>
99 Options Indexes FollowSymLinks MultiViews Includes
100 AllowOverride All
101 Require all granted
102 </Directory>
103 ''
104 ];
105 };
106 };
107 }