]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/denise/production.nix
Add Denise websites
[perso/Immae/Config/Nix.git] / modules / private / websites / denise / production.nix
1 { lib, config, pkgs, ... }:
2 let
3 cfg = config.myServices.websites.denise.production;
4 in {
5 options.myServices.websites.denise.production.enable = lib.mkEnableOption "enable Denise's website";
6
7 config = lib.mkIf cfg.enable {
8 services.websites.env.production.vhostConfs.denise_production = {
9 certName = "denise";
10 addToCerts = true;
11 hosts = [ "syanni.eu" "www.syanni.eu" ];
12 root = ../_www;
13 extraConfig = [
14 ''
15 <Directory ${../_www}>
16 DirectoryIndex index.htm index.html
17 Options Indexes FollowSymLinks MultiViews Includes
18 AllowOverride AuthConfig
19 Require all granted
20 </Directory>
21 ''
22 ];
23 };
24 };
25 }