]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/default.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
1 { lib, pkgs, config, ... }:
2 let
3 www_root = ./_www;
4 theme_root = pkgs.webapps.apache-theme.theme;
5 apacheConfig = {
6 cache = {
7 # This setting permits to ignore time-based cache for files in the
8 # nix store:
9 # If a client requires an If-Modified-Since from timestamp 1, then
10 # this header is removed, and if the response contains a
11 # too old Last-Modified tag, then it is removed too
12 extraConfig = ''
13 <If "%{HTTP:If-Modified-Since} =~ /01 Jan 1970 00:00:01/" >
14 RequestHeader unset If-Modified-Since
15 </If>
16 Header unset Last-Modified "expr=%{LAST_MODIFIED} < 19991231235959"
17 '';
18 };
19 gzip = {
20 modules = [ "deflate" "filter" ];
21 extraConfig = ''
22 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
23 '';
24 };
25 macros = {
26 modules = [ "macro" ];
27 };
28 stats = {
29 extraConfig = ''
30 <Macro Stats %{domain}>
31 Alias /webstats ${config.services.webstats.dataDir}/%{domain}
32 <Directory ${config.services.webstats.dataDir}/%{domain}>
33 DirectoryIndex index.html
34 AllowOverride None
35 Require all granted
36 </Directory>
37 <Location /webstats>
38 Use LDAPConnect
39 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
40 </Location>
41 </Macro>
42 '';
43 };
44 ldap = {
45 modules = [ "ldap" "authnz_ldap" ];
46 extraConfig = ''
47 <IfModule ldap_module>
48 LDAPSharedCacheSize 500000
49 LDAPCacheEntries 1024
50 LDAPCacheTTL 600
51 LDAPOpCacheEntries 1024
52 LDAPOpCacheTTL 600
53 </IfModule>
54
55 Include ${config.secrets.fullPaths."apache-ldap"}
56 '';
57 };
58 global = {
59 extraConfig = ''
60 ErrorDocument 500 /maintenance_immae.html
61 ErrorDocument 501 /maintenance_immae.html
62 ErrorDocument 502 /maintenance_immae.html
63 ErrorDocument 503 /maintenance_immae.html
64 ErrorDocument 504 /maintenance_immae.html
65 Alias /maintenance_immae.html ${www_root}/maintenance_immae.html
66 ProxyPass /maintenance_immae.html !
67
68 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${www_root}/googleb6d69446ff4ca3e5.html
69 <Directory ${www_root}>
70 AllowOverride None
71 Require all granted
72 </Directory>
73 '';
74 };
75 apaxy = {
76 extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
77 };
78 http2 = {
79 modules = [ "http2" ];
80 extraConfig = ''
81 Protocols h2 http/1.1
82 '';
83 };
84 customLog = {
85 extraConfig = ''
86 LogFormat "%{Host}i:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
87 '';
88 };
89 };
90 makeModules = lib.lists.flatten (lib.attrsets.mapAttrsToList (n: v: v.modules or []) apacheConfig);
91 makeExtraConfig = (builtins.filter (x: x != null) (lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) apacheConfig));
92 moomin = let
93 lines = lib.splitString "\n" (lib.fileContents ./moomin.txt);
94 pad = width: str: let
95 padWidth = width - lib.stringLength str;
96 padding = lib.concatStrings (lib.genList (lib.const "0") padWidth);
97 in lib.optionalString (padWidth > 0) padding + str;
98 in
99 lib.imap0 (i: e: ''Header always set "X-Moomin-${pad 2 (builtins.toString i)}" "${e}"'') lines;
100 in
101 {
102 options.myServices.websites.enable = lib.mkEnableOption "enable websites";
103
104 config = lib.mkIf config.myServices.websites.enable {
105 services.duplyBackup.profiles.php = {
106 rootDir = "/var/lib/php";
107 remotes = [ "eriomem" "ovh" ];
108 };
109 users.users.wwwrun.extraGroups = [ "keys" ];
110 networking.firewall.allowedTCPPorts = [ 80 443 ];
111
112 secrets.keys."apache-ldap" = {
113 user = "wwwrun";
114 group = "wwwrun";
115 permissions = "0400";
116 text = ''
117 <Macro LDAPConnect>
118 <IfModule authnz_ldap_module>
119 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
120 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
121 AuthLDAPBindPassword "${config.myEnv.httpd.ldap.password}"
122 AuthType Basic
123 AuthName "Authentification requise (Acces LDAP)"
124 AuthBasicProvider ldap
125 </IfModule>
126 </Macro>
127 '';
128 };
129
130 system.activationScripts = {
131 httpd = ''
132 install -d -m 0755 /var/lib/acme/acme-challenges
133 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
134 '';
135 };
136
137 services.phpfpm = {
138 phpOptions = ''
139 session.save_path = "/var/lib/php/sessions"
140 post_max_size = 20M
141 ; 15 days (seconds)
142 session.gc_maxlifetime = 1296000
143 ; 30 days (minutes)
144 session.cache_expire = 43200
145 '';
146 settings = {
147 log_level = "notice";
148 };
149 };
150
151 services.filesWatcher.httpdProd.paths = [ config.secrets.fullPaths."apache-ldap" ];
152 services.filesWatcher.httpdInte.paths = [ config.secrets.fullPaths."apache-ldap" ];
153 services.filesWatcher.httpdTools.paths = [ config.secrets.fullPaths."apache-ldap" ];
154
155 services.websites.env.production = {
156 enable = true;
157 adminAddr = "httpd@immae.eu";
158 httpdName = "Prod";
159 ips =
160 let ips = config.myEnv.servers.eldiron.ips.production;
161 in [ips.ip4] ++ (ips.ip6 or []);
162 modules = makeModules;
163 extraConfig = makeExtraConfig;
164 fallbackVhost = {
165 certName = "eldiron";
166 hosts = ["eldiron.immae.eu" ];
167 root = www_root;
168 extraConfig = [ "DirectoryIndex index.htm" ];
169 };
170 };
171
172 services.websites.env.integration = {
173 enable = true;
174 adminAddr = "httpd@immae.eu";
175 httpdName = "Inte";
176 ips =
177 let ips = config.myEnv.servers.eldiron.ips.integration;
178 in [ips.ip4] ++ (ips.ip6 or []);
179 modules = makeModules;
180 extraConfig = makeExtraConfig ++ moomin;
181 fallbackVhost = {
182 certName = "eldiron";
183 hosts = ["eldiron.immae.eu" ];
184 root = www_root;
185 extraConfig = [ "DirectoryIndex index.htm" ];
186 };
187 };
188
189 services.websites.env.tools = {
190 enable = true;
191 adminAddr = "httpd@immae.eu";
192 httpdName = "Tools";
193 ips =
194 let ips = config.myEnv.servers.eldiron.ips.main;
195 in [ips.ip4] ++ (ips.ip6 or []);
196 modules = makeModules;
197 extraConfig = makeExtraConfig ++
198 [ ''
199 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
200 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
201 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
202 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
203 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
204 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
205 ''
206 ];
207 nosslVhost = {
208 enable = true;
209 host = "nossl.immae.eu";
210 };
211 fallbackVhost = {
212 certName = "eldiron";
213 hosts = ["eldiron.immae.eu" ];
214 root = www_root;
215 extraConfig = [ "DirectoryIndex index.htm" ];
216 };
217 };
218
219 myServices.websites = {
220 bakeer.cloud.enable = true;
221 capitaines.landing_pages.enable = true;
222
223 chloe = {
224 integration.enable = true;
225 production.enable = true;
226 };
227
228 cip-ca = {
229 sympa.enable = true;
230 };
231
232 connexionswing = {
233 integration.enable = true;
234 production.enable = true;
235 };
236
237 denise = {
238 evariste.enable = true;
239 denisejerome.enable = true;
240 oms.enable = true;
241 bingo.enable = true;
242 aventuriers.enable = true;
243 production.enable = true;
244 };
245
246 emilia = {
247 moodle.enable = false;
248 atelierfringant.enable = true;
249 };
250
251 florian = {
252 app.enable = true;
253 integration.enable = true;
254 production.enable = true;
255 };
256
257 immae = {
258 production.enable = true;
259 release.enable = true;
260 temp.enable = true;
261 };
262
263 isabelle = {
264 aten_integration.enable = true;
265 aten_production.enable = true;
266 iridologie.enable = true;
267 };
268
269 jerome.naturaloutil.enable = true;
270
271 leila.production.enable = true;
272
273 ludivine = {
274 integration.enable = true;
275 production.enable = true;
276 };
277
278 nassime.production.enable = true;
279
280 nath.villon.enable = true;
281
282 papa = {
283 surveillance.enable = true;
284 maison_bbc.enable = true;
285 };
286
287 patrick_fodella.production.enable = true;
288
289 piedsjaloux = {
290 integration.enable = true;
291 production.enable = true;
292 };
293
294 ressourcerie_banon.production.enable = true;
295 ressourcerie_banon.cryptpad.enable = true;
296 ressourcerie_banon.cloud.enable = true;
297
298 richie.production.enable = true;
299
300 syden.peertube.enable = true;
301
302 telio_tortay.production.enable = true;
303
304 tools.assets.enable = true;
305 tools.cloud.enable = true;
306 tools.commento.enable = true;
307 tools.cryptpad.enable = true;
308 tools.dav.enable = true;
309 tools.db.enable = true;
310 tools.diaspora.enable = true;
311 tools.etherpad-lite.enable = true;
312 tools.git.enable = true;
313 tools.mastodon.enable = true;
314 tools.mediagoblin.enable = true;
315 tools.peertube.enable = true;
316 tools.performance.enable = true;
317 tools.tools.enable = true;
318 tools.email.enable = true;
319 tools.stats.enable = false;
320
321 games.codenames.enable = true;
322 games.terraforming-mars.enable = true;
323 };
324 };
325 }